aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-sphinx-tabs/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-04 00:06:11 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-04 00:06:11 +0000
commitb3331d7390abdbf73742c0c82012c92a76334496 (patch)
tree0ba72e910055972b4330da235a1de2b5b0ee7293 /textproc/py-sphinx-tabs/Makefile
parentfe804d0f598f6c89553a0a6f945e3d77bfcfdedb (diff)
Notes
Diffstat (limited to 'textproc/py-sphinx-tabs/Makefile')
-rw-r--r--textproc/py-sphinx-tabs/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/py-sphinx-tabs/Makefile b/textproc/py-sphinx-tabs/Makefile
new file mode 100644
index 000000000000..c0283f8d914b
--- /dev/null
+++ b/textproc/py-sphinx-tabs/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sphinx-tabs
+PORTVERSION= 1.1.10
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Tabbed views for Sphinx
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=1.4:textproc/py-sphinx@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>