aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-sphinx/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-07-17 12:46:02 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-07-17 12:46:02 +0000
commit742f9d77adbb51d41b1629e8e680d30c8c12b750 (patch)
tree00aa48b2287da3c9ea7221830b18f33bb474b046 /textproc/py-sphinx/Makefile
parent72d85db09b7b00a5f8e83bf43fee8bd9473d426d (diff)
downloadports-742f9d77adbb51d41b1629e8e680d30c8c12b750.tar.gz
ports-742f9d77adbb51d41b1629e8e680d30c8c12b750.zip
Notes
Diffstat (limited to 'textproc/py-sphinx/Makefile')
-rw-r--r--textproc/py-sphinx/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/textproc/py-sphinx/Makefile b/textproc/py-sphinx/Makefile
index 9dd95e04295c..36c33c4db73b 100644
--- a/textproc/py-sphinx/Makefile
+++ b/textproc/py-sphinx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sphinx
PORTVERSION= 1.1.3
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -26,4 +27,10 @@ USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= Sphinx
+PLIST_SUB= PYTHON_VER=${PYTHON_VER}
+
+post-install:
+ @${SETENV} PYTHONPATH=${PYTHONPREFIX_SITELIBDIR} \
+ ${PYTHON_CMD} -m sphinx.pycode.pgen2.driver -c 'import load_grammar'
+
.include <bsd.port.mk>