aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-tabletext
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2017-02-14 17:07:10 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2017-02-14 17:07:10 +0000
commitf6ebf6cceb5a6544fe3533b90baeb4a33b242c01 (patch)
tree1206d2b0feee0336221de2610e585eb934e5a39d /textproc/py-tabletext
parentfc4fc033d7f85d7669e89745b418e80a0488a9e0 (diff)
downloadports-f6ebf6cceb5a6544fe3533b90baeb4a33b242c01.tar.gz
ports-f6ebf6cceb5a6544fe3533b90baeb4a33b242c01.zip
Notes
Diffstat (limited to 'textproc/py-tabletext')
-rw-r--r--textproc/py-tabletext/files/patch-setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/textproc/py-tabletext/files/patch-setup.py b/textproc/py-tabletext/files/patch-setup.py
new file mode 100644
index 000000000000..16764b793241
--- /dev/null
+++ b/textproc/py-tabletext/files/patch-setup.py
@@ -0,0 +1,23 @@
+--- setup.py.orig 2014-08-14 18:05:14 UTC
++++ setup.py
+@@ -1,13 +1,18 @@
+ #!/usr/bin/env python
+
+ from setuptools import setup
++import sys
++
++open_kwargs = {}
++if sys.version_info.major >= 3:
++ open_kwargs['encoding'] = 'utf8'
+
+ setup(name='tabletext',
+ version='0.1',
+ description='Python library and command line utility to pretty-print\
+ tabular data',
+- long_description=open("README.rst").read() + "\n"
+- + open("CHANGELOG.rst").read(),
++ long_description=open("README.rst", **open_kwargs).read() + "\n"
++ + open("CHANGELOG.rst", **open_kwargs).read(),
+ url='https://github.com/Thibauth/tabletext',
+ author='Thibaut Horel',
+ author_email='thibaut.horel+tabletext@gmail.com',