aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-xml/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-03-23 00:47:52 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-03-23 00:47:52 +0000
commit1a8bdc02e5a63aadbdb329d64b2346a9a6da7d4d (patch)
treee22a862bdbd4e72420896414fe5ed4ee0676de62 /textproc/py-xml/Makefile
parent77c6a12660e9d4d5e0b706f57d0072d8163f73ba (diff)
downloadports-1a8bdc02e5a63aadbdb329d64b2346a9a6da7d4d.tar.gz
ports-1a8bdc02e5a63aadbdb329d64b2346a9a6da7d4d.zip
Notes
Diffstat (limited to 'textproc/py-xml/Makefile')
-rw-r--r--textproc/py-xml/Makefile27
1 files changed, 18 insertions, 9 deletions
diff --git a/textproc/py-xml/Makefile b/textproc/py-xml/Makefile
index c912419d88a0..a2a6bd2cf4d4 100644
--- a/textproc/py-xml/Makefile
+++ b/textproc/py-xml/Makefile
@@ -6,12 +6,9 @@
#
PORTNAME= xml
-PORTVERSION= 0.6.4
+PORTVERSION= 0.6.5
CATEGORIES= textproc python
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.python.org/sigs/xml-sig/files/ \
- ftp://ftp.cdrom.com/pub/python/www.python.org/sigs/xml-sig/files/ \
- ftp://unix.hensa.ac.uk/mirrors/ftp.python.org/pub/www.python.org/sigs/xml-sig/files/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pyxml
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyXML-${PORTVERSION}
@@ -20,12 +17,17 @@ MAINTAINER= johann@egenetics.com
BUILD_DEPENDS= ${PYDISTUTILS}
+INSTALLS_SHLIB= yes
+# On a system with more than one version of Python installed, you can force
+# this port to install for a specific version of Python by explicitly setting
+# ${PYTHON_VERSION} during build/installation.
USE_PYTHON= yes
.include <bsd.port.pre.mk>
CPIO= cpio --quiet -pdum -R
DOCDIR= ${PREFIX}/share/doc/py-xml
+EGDIR= ${PREFIX}/share/examples/py-xml
.if ${PYTHON_VERSION} == "python1.5"
PLIST_SUB+= PACKAGE_DIR=xml
.else
@@ -33,16 +35,23 @@ PLIST_SUB+= PACKAGE_DIR=_xmlplus
.endif
do-build:
- @ (cd ${WRKSRC} && ${PYTHON_CMD} setup.py build)
+ @ cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
do-install:
- @ (cd ${WRKSRC} && ${PYTHON_CMD} setup.py install)
+ @ cd ${WRKSRC} && ${PYTHON_CMD} setup.py install -c -O1 \
+ --prefix=${PREFIX}
post-install:
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCDIR}
- @ (cd ${WRKSRC}/doc && find . \
- | ${CPIO} ${MANOWN}:${MANGRP} ${DOCDIR})
+.for docfile in ANNOUNCE CREDITS LICENCE README* TODO
+ @ ${INSTALL_MAN} ${WRKSRC}/${docfile} ${DOCDIR}
+.endfor
+ @ cd ${WRKSRC}/doc && find * \
+ | ${CPIO} ${MANOWN}:${MANGRP} ${DOCDIR}
+ @ ${MKDIR} ${EGDIR}
+ @ cd ${WRKSRC} && find demo test \
+ | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EGDIR}
.endif
.include <bsd.port.post.mk>