aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-xml
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-27 22:27:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-27 22:27:43 +0000
commit9477d933b7dcd4aee46dc2641324d8bca7331b60 (patch)
tree48c6702774579e714439df839049274ef12b7a6f /textproc/py-xml
parent59c4527e00e5b02c0f5ea165f8790067a21166d9 (diff)
downloadports-9477d933b7dcd4aee46dc2641324d8bca7331b60.tar.gz
ports-9477d933b7dcd4aee46dc2641324d8bca7331b60.zip
Notes
Diffstat (limited to 'textproc/py-xml')
-rw-r--r--textproc/py-xml/Makefile2
-rw-r--r--textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedAbsoluteLocationPath.py13
-rw-r--r--textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedRelativeLocationPath.py13
-rw-r--r--textproc/py-xml/pkg-plist4
4 files changed, 31 insertions, 1 deletions
diff --git a/textproc/py-xml/Makefile b/textproc/py-xml/Makefile
index 3849da072783..a74dc98ffa40 100644
--- a/textproc/py-xml/Makefile
+++ b/textproc/py-xml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xml
PORTVERSION= 0.8.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pyxml
diff --git a/textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedAbsoluteLocationPath.py b/textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedAbsoluteLocationPath.py
new file mode 100644
index 000000000000..1aa89d886448
--- /dev/null
+++ b/textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedAbsoluteLocationPath.py
@@ -0,0 +1,13 @@
+--- xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py.orig 2009-07-09 08:48:55.000000000 +0800
++++ xml/xpath/ParsedAbbreviatedAbsoluteLocationPath.py 2009-07-09 08:49:09.000000000 +0800
+@@ -24,8 +24,8 @@
+ self._rel = rel
+ nt = ParsedNodeTest.ParsedNodeTest('node', '')
+ ppl = ParsedPredicateList.ParsedPredicateList([])
+- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
+- self._step = ParsedStep.ParsedStep(as, nt, ppl)
++ as26 = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
++ self._step = ParsedStep.ParsedStep(as26, nt, ppl)
+ return
+
+ def evaluate(self, context):
diff --git a/textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedRelativeLocationPath.py b/textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedRelativeLocationPath.py
new file mode 100644
index 000000000000..c440b2455c24
--- /dev/null
+++ b/textproc/py-xml/files/patch-xml-xpath-ParsedAbbreviatedRelativeLocationPath.py
@@ -0,0 +1,13 @@
+--- xml/xpath/ParsedAbbreviatedRelativeLocationPath.py.orig 2009-07-09 08:43:39.000000000 +0800
++++ xml/xpath/ParsedAbbreviatedRelativeLocationPath.py 2009-07-09 08:43:56.000000000 +0800
+@@ -28,8 +28,8 @@
+ self._right = right
+ nt = ParsedNodeTest.ParsedNodeTest('node','')
+ ppl = ParsedPredicateList.ParsedPredicateList([])
+- as = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
+- self._middle = ParsedStep.ParsedStep(as, nt, ppl)
++ as26 = ParsedAxisSpecifier.ParsedAxisSpecifier('descendant-or-self')
++ self._middle = ParsedStep.ParsedStep(as26, nt, ppl)
+
+ def evaluate(self, context):
+ res = []
diff --git a/textproc/py-xml/pkg-plist b/textproc/py-xml/pkg-plist
index 792c96a32e69..4129e958ba1c 100644
--- a/textproc/py-xml/pkg-plist
+++ b/textproc/py-xml/pkg-plist
@@ -532,7 +532,11 @@ bin/xmlproc_val
%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/NamespaceNode.pyc
%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/NamespaceNode.pyo
%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbbreviatedAbsoluteLocationPath.py
+%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbbreviatedAbsoluteLocationPath.pyc
+%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbbreviatedAbsoluteLocationPath.pyo
%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbbreviatedRelativeLocationPath.py
+%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbbreviatedRelativeLocationPath.pyc
+%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbbreviatedRelativeLocationPath.pyo
%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbsoluteLocationPath.py
%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbsoluteLocationPath.pyc
%%XPATH%%%%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/xpath/ParsedAbsoluteLocationPath.pyo