aboutsummaryrefslogtreecommitdiff
path: root/textproc/py2html/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-28 23:58:15 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-28 23:58:15 +0000
commita143d4ff77fb496d88421863dbabba5ffe1838ea (patch)
tree544253549a6892b55c8d5c80e51e132d706506b4 /textproc/py2html/Makefile
parentc2ca15ccb1305302f0b1db315dd9845ea2d8a9bd (diff)
downloadports-a143d4ff77fb496d88421863dbabba5ffe1838ea.tar.gz
ports-a143d4ff77fb496d88421863dbabba5ffe1838ea.zip
Notes
Diffstat (limited to 'textproc/py2html/Makefile')
-rw-r--r--textproc/py2html/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/py2html/Makefile b/textproc/py2html/Makefile
new file mode 100644
index 000000000000..8aec0198891f
--- /dev/null
+++ b/textproc/py2html/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py2html
+# Date created: 15 Nov 2000
+# Whom: Hye-Shik Chang <perky@python.or.kr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= py2html
+PORTVERSION= 0.6
+CATEGORIES= textproc www python
+MASTER_SITES= http://dist.freebsd-kr.org/pub/FreeBSD/ports/distfiles/ \
+ ftp://ftp2.python.or.kr/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= perky@python.or.kr
+
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON_LIBPATH=${PYTHON_LIBPATH:S/^${LOCALBASE}//g}lib \
+ PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/PyFontify.py* ${PYTHON_SITELIBDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/py2html.py ${LOCALBASE}/bin/py2html
+ ${INSTALL_SCRIPT} ${WRKSRC}/py2html.pyc ${LOCALBASE}/bin/
+
+.include <bsd.port.mk>