aboutsummaryrefslogtreecommitdiff
path: root/textproc/raptor/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-22 10:02:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-22 10:02:31 +0000
commitb26237b863fc00f7d8d130a26dd942c9ac70beba (patch)
tree9434bf85d3b8c2e20a33a369c0136cbf1e8b78a0 /textproc/raptor/Makefile
parentf307a822e6a7bc43688b9a6c9566d69d47a5ca9d (diff)
downloadports-b26237b863fc00f7d8d130a26dd942c9ac70beba.tar.gz
ports-b26237b863fc00f7d8d130a26dd942c9ac70beba.zip
Notes
Diffstat (limited to 'textproc/raptor/Makefile')
-rw-r--r--textproc/raptor/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/raptor/Makefile b/textproc/raptor/Makefile
new file mode 100644
index 000000000000..c9632af211b0
--- /dev/null
+++ b/textproc/raptor/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: raptor
+# Date created: Nov 22, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= raptor
+PORTVERSION= 0.9.3
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.redland.opensource.ac.uk/dist/source/
+MASTER_SITE_SUBDIR= librdf
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= expat.2:${PORTSDIR}/textproc/expat2 \
+ xmlparse:${PORTSDIR}/www/libwww \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+LIBWWW_CONFIG= ${LOCALBASE}/bin/libwww-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include `${LIBWWW_CONFIG} --cflags`" \
+ LIBS="-L${LOCALBASE}/lib -lgnugetopt `${LIBWWW_CONFIG} --libs`"
+
+.include <bsd.port.mk>