aboutsummaryrefslogtreecommitdiff
path: root/textproc/rasqal/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-09-24 14:05:51 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-09-24 14:05:51 +0000
commitfeba4e356c02ec2b74c5b61cc7870fe2cc2bec4b (patch)
treee3184069bd4a6176c5014a1146be37847e209648 /textproc/rasqal/Makefile
parent1760d60f5f85fa762b3d0945ea7f9fd82e919391 (diff)
downloadports-feba4e356c02ec2b74c5b61cc7870fe2cc2bec4b.tar.gz
ports-feba4e356c02ec2b74c5b61cc7870fe2cc2bec4b.zip
Notes
Diffstat (limited to 'textproc/rasqal/Makefile')
-rw-r--r--textproc/rasqal/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/textproc/rasqal/Makefile b/textproc/rasqal/Makefile
index ed7961004919..565e55b7fe7a 100644
--- a/textproc/rasqal/Makefile
+++ b/textproc/rasqal/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= redland
-PORTVERSION= 0.9.13
+PORTVERSION= 0.9.14
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.redland.opensource.ac.uk/dist/source/
@@ -17,33 +17,25 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A high-level interface for RDF
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db2 \
- raptor.0:${PORTSDIR}/textproc/raptor
+ raptor.1:${PORTSDIR}/textproc/raptor
USE_OPENSSL= yes
-USE_REINPLACE= yes
+USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-bdb-lib="${LOCALBASE}/lib" \
--with-bdb-include="${LOCALBASE}/include/db2" \
--with-bdb-dbname="db2" \
- --with-libwww
+ --with-libwww \
+ --with-raptor=system
INSTALLS_SHLIB= yes
-MAN1= redland-config.1 redland-db-upgrade.1
+MAN1= rdfproc.1 redland-config.1 redland-db-upgrade.1
MAN3= redland.3
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-post-patch:
- @${REINPLACE_CMD} -e 's|ac_subdirs_all raptor|ac_subdirs_all|g ; \
- s|-I\\$$(top_srcdir)/raptor||g ; \
- s|\\$$(top_builddir)/raptor/libraptor.la|-lraptor|g' \
- ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|SUBDIRS = raptor|SUBDIRS =|g ; \
- s|$$(top_builddir)/raptor/libraptor.la|-lraptor|g'
-
.include <bsd.port.mk>