aboutsummaryrefslogtreecommitdiff
path: root/textproc/redisearch
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2020-02-25 23:31:27 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2020-02-25 23:31:27 +0000
commite79e1d82260e626356fa081c49c08a0acc948bc3 (patch)
tree45f0f797c97d987f3ee3515e879c6b0d66279c0b /textproc/redisearch
parent201f66007ad7bf19e4885fea26b18d69482a1d00 (diff)
downloadports-e79e1d82260e626356fa081c49c08a0acc948bc3.tar.gz
ports-e79e1d82260e626356fa081c49c08a0acc948bc3.zip
Notes
Diffstat (limited to 'textproc/redisearch')
-rw-r--r--textproc/redisearch/Makefile30
-rw-r--r--textproc/redisearch/distinfo3
-rw-r--r--textproc/redisearch/pkg-descr12
3 files changed, 45 insertions, 0 deletions
diff --git a/textproc/redisearch/Makefile b/textproc/redisearch/Makefile
new file mode 100644
index 000000000000..1b20815b06cd
--- /dev/null
+++ b/textproc/redisearch/Makefile
@@ -0,0 +1,30 @@
+# Created by: Sergey A. Osokin <osa@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= redisearch
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4.24
+CATEGORIES= textproc
+
+MAINTAINER= osa@FreeBSD.org
+COMMENT= Full-text search over Redis
+
+LICENSE= UNKNOWN
+LICENSE_NAME= Redis Source Available License Agreement
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+USES= cmake
+
+USE_GITHUB= yes
+GH_ACCOUNT= RediSearch
+GH_PROJECT= RediSearch
+
+CMAKE_ARGS= -DGIT_DESCRIBE_VERSION:STRING=${PKGVERSION}
+
+PLIST_FILES= lib/redisearch.so
+
+do-install:
+ ${INSTALL_LIB} ${INSTALL_WRKSRC}/redisearch.so ${STAGEDIR}${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/textproc/redisearch/distinfo b/textproc/redisearch/distinfo
new file mode 100644
index 000000000000..630658b45446
--- /dev/null
+++ b/textproc/redisearch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582247654
+SHA256 (RediSearch-RediSearch-v1.4.24_GH0.tar.gz) = 7b0ff9ddfde9e235098f323d2f8ff53d58df87e43f3ada95aa0af4568a3d6ddd
+SIZE (RediSearch-RediSearch-v1.4.24_GH0.tar.gz) = 3573486
diff --git a/textproc/redisearch/pkg-descr b/textproc/redisearch/pkg-descr
new file mode 100644
index 000000000000..ac2a0a714490
--- /dev/null
+++ b/textproc/redisearch/pkg-descr
@@ -0,0 +1,12 @@
+RediSearch is a source available Full-Text and Secondary Index
+engine over Redis, developed by Redis Labs.
+
+Redisearch implements a search engine on top of Redis, but
+unlike other Redis search libraries, it does not use internal
+data structures like sorted sets.
+
+This also enables more advanced features, like exact phrase
+matching and numeric filtering for text queries, that are not
+possible or efficient with traditional Redis search approaches.
+
+WWW: https://oss.redislabs.com/redisearch/