aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland-bindings
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-05-11 17:05:54 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-05-11 17:05:54 +0000
commit072ab847ec332545d343141c481ea5515fb10875 (patch)
treef7fda9fd4f57e3e58177c400bbebd2ecebb94826 /textproc/redland-bindings
parentb9abf8a16840f0782adb165055e8009c219c2535 (diff)
downloadports-072ab847ec332545d343141c481ea5515fb10875.tar.gz
ports-072ab847ec332545d343141c481ea5515fb10875.zip
Notes
Diffstat (limited to 'textproc/redland-bindings')
-rw-r--r--textproc/redland-bindings/Makefile11
-rw-r--r--textproc/redland-bindings/distinfo4
-rw-r--r--textproc/redland-bindings/files/patch-configure42
-rw-r--r--textproc/redland-bindings/pkg-plist3
4 files changed, 52 insertions, 8 deletions
diff --git a/textproc/redland-bindings/Makefile b/textproc/redland-bindings/Makefile
index 699c94527878..8669727ecbd3 100644
--- a/textproc/redland-bindings/Makefile
+++ b/textproc/redland-bindings/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= redland-bindings
-PORTVERSION= 1.0.16.1
-CATEGORIES?= textproc
+PORTVERSION= 1.0.17.1
+CATEGORIES= textproc
MASTER_SITES= http://download.librdf.org/source/
-MAINTAINER?= kde@FreeBSD.org
-COMMENT?= Language bindings for the Redland package
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Language bindings for the Redland package
# Even though GPLv3 is not explicitly mentioned in the port's LICENSE.html, one
# of its licenses is "GPLv2 or newer", which includes GPLv3.
@@ -28,7 +28,7 @@ PERL_USES= perl5
PHP_CONFIGURE_WITH= php
PHP_USE= PHP=yes PHP_BUILD=yes
PYTHON_CONFIGURE_WITH= python
-PYTHON_USE= PYTHON=2.5+
+PYTHON_USE= PYTHON=yes
RUBY_CONFIGURE_WITH= ruby
RUBY_USE= RUBY=yes
@@ -37,6 +37,7 @@ RUBY_USE= RUBY=yes
post-install:
.if ${PORT_OPTIONS:MPERL}
${RM} ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/mach/perllocal.pod
+ ${SED} -i '' -e 's,^${STAGEDIR},,g' ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/RDF/Redland/CORE/.packlist
.endif
.include <bsd.port.mk>
diff --git a/textproc/redland-bindings/distinfo b/textproc/redland-bindings/distinfo
index 78860ce7e290..0f32cd39ef0c 100644
--- a/textproc/redland-bindings/distinfo
+++ b/textproc/redland-bindings/distinfo
@@ -1,2 +1,2 @@
-SHA256 (redland-bindings-1.0.16.1.tar.gz) = 065037ef61e9b78f642e75b9c2a42700eb1a87d903f2f9963d86591c7d916826
-SIZE (redland-bindings-1.0.16.1.tar.gz) = 859166
+SHA256 (redland-bindings-1.0.17.1.tar.gz) = ff72b587ab55f09daf81799cb3f9d263708fad5df7a5458f0c28566a2563b7f5
+SIZE (redland-bindings-1.0.17.1.tar.gz) = 933290
diff --git a/textproc/redland-bindings/files/patch-configure b/textproc/redland-bindings/files/patch-configure
new file mode 100644
index 000000000000..44918a4fc576
--- /dev/null
+++ b/textproc/redland-bindings/files/patch-configure
@@ -0,0 +1,42 @@
+Compatibility with Ruby < 2.0, where RbConfig::CONFIG['rubyarchhdrdir'] does not exist.
+Submitted upstream: https://github.com/dajobe/redland-bindings/pull/8
+
+Fetch redland.so's suffix from the right variable.
+Submitted upstream: https://github.com/dajobe/redland-bindings/pull/9
+--- configure.orig 2014-05-11 17:39:24.000000000 +0300
++++ configure 2014-05-11 17:39:27.000000000 +0300
+@@ -12297,6 +12297,7 @@
+ RUBY_ARCHDIR=`$RUBY -rrbconfig -e "print RbConfig::CONFIG['archdir']"`
+ ruby_install_dir_config=`$RUBY -rrbconfig -e "puts RbConfig::CONFIG['$ruby_install_dir_variable']"`
+ ruby_header_dir_config=`$RUBY -rrbconfig -e "puts RbConfig::CONFIG['rubyhdrdir']"`
++ ruby_arch_config=`$RUBY -rrbconfig -e "puts RbConfig::CONFIG['arch']"`
+ ruby_arch_header_dir_config=`$RUBY -rrbconfig -e "puts RbConfig::CONFIG['rubyarchhdrdir']"`
+ ruby_arch_install_dir_config=`$RUBY -rrbconfig -e "puts RbConfig::CONFIG['$ruby_arch_install_dir_variable']"`
+ librubyarg_shared=`$RUBY -rrbconfig -e "puts RbConfig::CONFIG['LIBRUBYARG_SHARED']"`
+@@ -12328,9 +12329,15 @@
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking Ruby headers dir" >&5
+ $as_echo_n "checking Ruby headers dir... " >&6; }
+ if test "X$ruby_header_dir_config" != "Xnil" -a "X$ruby_header_dir_config" != "X"; then
+- RUBY_INCLUDES="$RUBY_INCLUDES -I$ruby_header_dir_config -I$ruby_arch_header_dir_config"
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $RUBY_INCLUDES from RbConfig::CONFIG rubyhdrdir and rubyarchhdrdir" >&5
++ if test -d "$ruby_arch_header_dir_config"; then
++ RUBY_INCLUDES="$RUBY_INCLUDES -I$ruby_header_dir_config -I$ruby_arch_header_dir_config"
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $RUBY_INCLUDES from RbConfig::CONFIG rubyhdrdir and rubyarchhdrdir" >&5
+ $as_echo "$RUBY_INCLUDES from RbConfig::CONFIG rubyhdrdir and rubyarchhdrdir" >&6; }
++ elif test -d "$ruby_header_dir_config/$ruby_arch_config"; then
++ RUBY_INCLUDES="$RUBY_INCLUDES -I$ruby_header_dir_config -I$ruby_header_dir_config/$ruby_arch_config"
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $RUBY_INCLUDES from RbConfig::CONFIG rubyhdrdir and arch" >&5
++$as_echo "$RUBY_INCLUDES from RbConfig::CONFIG rubyhdrdir and arch" >&6; }
++ fi
+ else
+ if test -r "$RUBY_ARCHDIR/ruby.h"; then
+ RUBY_INCLUDES="$RUBY_INCLUDES -I$RUBY_ARCHDIR"
+@@ -12371,7 +12378,7 @@
+ as_fn_error $? "No such RUBY linking type $ruby_linking" "$LINENO" 5
+ ;;
+ esac
+- RUBY_SO_SUFFIX=$php_linking
++ RUBY_SO_SUFFIX=$ruby_linking
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking Ruby Linking" >&5
+ $as_echo_n "checking Ruby Linking... " >&6; }
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: compile '$RUBY_CFLAGS' link '$RUBY_LDFLAGS' suffix $RUBY_SO_SUFFIX" >&5
diff --git a/textproc/redland-bindings/pkg-plist b/textproc/redland-bindings/pkg-plist
index 775c5f6b5ce9..321881d9870d 100644
--- a/textproc/redland-bindings/pkg-plist
+++ b/textproc/redland-bindings/pkg-plist
@@ -37,8 +37,9 @@
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RDF/Redland/CORE/CORE.bs
%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/RDF/Redland/CORE/CORE.so
%%PHP%%lib/php/%%PHP_EXT_DIR%%/redland.so
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/Redland.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/RDF.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/Redland.py
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/_Redland.so
%%RUBY%%%%RUBY_ARCHLIBDIR%%/redland.so
%%RUBY%%%%RUBY_LIBDIR%%/rdf/redland/constants.rb
%%RUBY%%%%RUBY_LIBDIR%%/rdf/redland/convert_owl.rb