aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-22 07:03:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-22 07:03:00 +0000
commit4bff3754b15fadbcceff88f773130a5f9033db15 (patch)
tree2b4cfc76e711c852e7d8d350c29dc8a5d375433d /textproc/redland/Makefile
parent5b63b2b0cbe7eb2954167ad807f5bbc2afe4d50a (diff)
downloadports-4bff3754b15fadbcceff88f773130a5f9033db15.tar.gz
ports-4bff3754b15fadbcceff88f773130a5f9033db15.zip
Notes
Diffstat (limited to 'textproc/redland/Makefile')
-rw-r--r--textproc/redland/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
new file mode 100644
index 000000000000..d4b37d2da6c3
--- /dev/null
+++ b/textproc/redland/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: redland
+# Date created: Nov 22, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= redland
+PORTVERSION= 0.9.10
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.redland.opensource.ac.uk/dist/source/
+MASTER_SITE_SUBDIR= librdf
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= xmlparse.1:${PORTSDIR}/www/libwww \
+ expat.2:${PORTSDIR}/textproc/expat2 \
+ gdbm:${PORTSDIR}/databases/gdbm \
+ db2:${PORTSDIR}/databases/db
+
+USE_OPENSSL= yes
+LIBWWW_CONFIG= ${LOCALBASE}/bin/libwww-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} `${LIBWWW_CONFIG} --cflags` -I${LOCALBASE}/include/db2" \
+ LDFLAGS="`${LIBWWW_CONFIG} --libs`"
+CONFIGURE_ARGS= --with-bdb=${LOCALBASE} --with-libwww
+
+.include <bsd.port.mk>