aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-05-11 12:23:23 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-05-11 12:23:23 +0000
commitb9e8e9b771669739b315082c52fca22eda504a7c (patch)
tree8ab43052c7d654026f0182d3561ef5c924ab236c /textproc/redland
parentafe8a0b09a357395514cdb2894bb56077c0f7371 (diff)
downloadports-b9e8e9b771669739b315082c52fca22eda504a7c.tar.gz
ports-b9e8e9b771669739b315082c52fca22eda504a7c.zip
Notes
Diffstat (limited to 'textproc/redland')
-rw-r--r--textproc/redland/Makefile89
-rw-r--r--textproc/redland/distinfo6
-rw-r--r--textproc/redland/files/patch-Makefile.in14
-rw-r--r--textproc/redland/files/patch-configure15
-rw-r--r--textproc/redland/pkg-plist52
5 files changed, 83 insertions, 93 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index affb15efb9bc..76f9ede87ac5 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -7,22 +7,22 @@
#
PORTNAME= redland
-PORTVERSION= 1.0.7
-PORTREVISION= 2
+PORTVERSION= 1.0.10
CATEGORIES= textproc
MASTER_SITES= SF/librdf/${PORTNAME}/${PORTVERSION} \
http://librdf.org/dist/source/
-
MAINTAINER= kde@FreeBSD.org
COMMENT= A high-level interface for RDF
-LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
+LIB_DEPENDS= raptor.3:${PORTSDIR}/textproc/raptor \
+ rasqal.2:${PORTSDIR}/textproc/rasqal
USE_BDB= yes
WITH_BDB_HIGHEST= yes
INVALID_BDB_VER=2
-USE_GNOME= gnomehack gnometarget lthack pkgconfig
+USE_GNOME= gnomehack gnometarget lthack pkgconfig libxml2
+USE_AUTOTOOLS= libltdl:22
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -31,44 +31,67 @@ CPPFLAGS= -I${BDB_INCLUDE_DIR} -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-raptor=system \
- --with-rasqal=internal \
- --with-threestore=no \
- --with-sqlite=no
+ --with-threestore=no
USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
-MAN1= rasqal-config.1 rdfproc.1 redland-config.1 \
- redland-db-upgrade.1 roqet.1
-MAN3= librasqal.3 redland.3
+MAN1= rdfproc.1 redland-config.1 \
+ redland-db-upgrade.1
+MAN3= redland.3
-OPTIONS+= MYSQL "Use MySQL instead of BDB" off
-OPTIONS+= MPFR "Use MPFR library for decimals (implies GMP)" off
-OPTIONS+= GMP "Use Gnu MP library for decimals" off
+OPTIONS+= THREADS "Enable Threads" off
+# MYSQL "Use MySQL instead of BDB" off \
+# PGSQL "Use PgSQL instead of BDB" off \
+# SQLITE "Use SQLite instead of BDB" off \
+# VIRTUOSO "Use Virtoso instead of BDB" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql=yes
-PLIST_SUB+= MYSQL=""
+.if defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --disable-threads
.else
+CONFIGURE_ARGS+= --enable-threads
+.endif
+
+#.if defined(WITH_MYSQL)
+#USE_MYSQL= yes
+#CONFIGURE_ARGS+=--with-mysql=yes
+#CONFIGURE_ENV+= LIBS="${LIBS}"
+#CFLAGS+= -I${LOCALBASE}/include/mysql -DHAVE_MYSQL_H
+#LDFLAGS+= -L${LOCALBASE}/lib/mysql
+#PLIST_SUB+= MYSQL=""
+#.else
CONFIGURE_ARGS+=--with-mysql=no
PLIST_SUB+= MYSQL="@comment "
-.endif
+#.endif
-# Set to mpfr if MPFR is on, gmp if only GMP is on and none if neither.
-# This guards against $user setting both GMP and MPFR, since we can't be
-# very verbose in explaining our options.
-.if defined(WITH_MPFR)
-CONFIGURE_ARGS+= --with-decimal=mpfr
-LIB_DEPENDS+= mpfr.3:${PORTSDIR}/math/mpfr
-.elif defined(WITH_GMP)
-CONFIGURE_ARGS+= --with-decimal=gmp
-LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
-.else
-CONFIGURE_ARGS+= --with-decimal=none
-.endif
+#.if defined(WITH_PGSQL)
+#USE_PGSQL= yes
+#CONFIGURE_ARGS+=--with-postgresql=yes
+#PLIST_SUB+= PGSQL=""
+#.else
+CONFIGURE_ARGS+=--with-postgresql=no
+PLIST_SUB+= PGSQL="@comment "
+#.endif
+
+#.if defined(WITH_SQLITE)
+#USE_SQLITE= 3
+#CONFIGURE_ARGS+=--with-sqlite=3
+#PLIST_SUB+= SQLITE=""
+#.else
+CONFIGURE_ARGS+=--with-sqlite=no
+PLIST_SUB+= SQLITE="@comment "
+#.endif
+
+#.if defined(WITH_VIRTUOSO)
+#CONFIGURE_ARGS+=--with-virtuoso=yes
+#LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+#PLIST_SUB+= VIRTUOSO=""
+#.else
+CONFIGURE_ARGS+=--with-virtuoso=no
+PLIST_SUB+= VIRTUOSO="@comment "
+#.endif
pre-everything::
@${ECHO_CMD} "You can choose BDB version by setting WITH_BDB_VER to one off:"
@@ -79,4 +102,4 @@ pre-everything::
@${ECHO_CMD} "and set WITH_MYSQL_VER to the desired version"
. endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/redland/distinfo b/textproc/redland/distinfo
index e54a28975bfb..1de42d185489 100644
--- a/textproc/redland/distinfo
+++ b/textproc/redland/distinfo
@@ -1,3 +1,3 @@
-MD5 (redland-1.0.7.tar.gz) = 4c066d3dcf6c25f8fb8c9007e73f293c
-SHA256 (redland-1.0.7.tar.gz) = 5fe48265b770bae89c47b3a55711adbfba368dfa120ab8112bde539b210426fc
-SIZE (redland-1.0.7.tar.gz) = 3739013
+MD5 (redland-1.0.10.tar.gz) = bdbb9b8dc614fc09a14cd646079619e1
+SHA256 (redland-1.0.10.tar.gz) = e3060d05de27c72fb1d1c8ebb698006462abcb96bff98511c0baf08d85389815
+SIZE (redland-1.0.10.tar.gz) = 1569554
diff --git a/textproc/redland/files/patch-Makefile.in b/textproc/redland/files/patch-Makefile.in
index eb18debc2f80..cbb15b307ba4 100644
--- a/textproc/redland/files/patch-Makefile.in
+++ b/textproc/redland/files/patch-Makefile.in
@@ -1,11 +1,11 @@
--- Makefile.in.orig Wed Aug 4 12:17:19 2004
+++ Makefile.in Wed Aug 4 12:18:49 2004
-@@ -257,7 +257,7 @@
- # to ensure that the raptor and rasqal subdirectories are called
- # as CONFIG_SUBDIR directories.
- #
--SUBDIRS = @LOCAL_SUBDIRS@ librdf examples utils demos docs data
-+SUBDIRS = @LOCAL_SUBDIRS@ librdf utils demos docs data
+@@ -288,7 +288,7 @@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
+
+ # Subdirectories to build/install/distribute etc.
+-SUBDIRS = $(subdirs) src examples utils demos docs data
++SUBDIRS = $(subdirs) src utils demos docs data
EXTRA_DIST = ChangeLog ChangeLog.1 ChangeLog.2 ChangeLog.3 ChangeLog.4 \
+ ChangeLog.5 ChangeLog.6 ChangeLog.7 \
README NEWS LICENSE.txt TODO \
- README.html NEWS.html LICENSE.html TODO.html \
diff --git a/textproc/redland/files/patch-configure b/textproc/redland/files/patch-configure
deleted file mode 100644
index bdb0881dd344..000000000000
--- a/textproc/redland/files/patch-configure
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.orig Tue Sep 9 00:06:31 2003
-+++ configure Tue Sep 9 09:03:46 2003
-@@ -12735,9 +12735,9 @@
- CFLAGS="$MAINTAINER_CFLAGS $CFLAGS"
- fi
-
--LIBS=
--CPPFLAGS=
--LDFLAGS=
-+LIBS="$LIBS"
-+CPPFLAGS="$CPPFLAGS"
-+LDFLAGS="$LDFLAGS"
-
- LIBRDF_LIBTOOLLIBS=librdf.la
-
diff --git a/textproc/redland/pkg-plist b/textproc/redland/pkg-plist
index 114cbe7d148d..6af38683a482 100644
--- a/textproc/redland/pkg-plist
+++ b/textproc/redland/pkg-plist
@@ -1,62 +1,44 @@
-bin/rasqal-config
bin/rdfproc
bin/redland-config
bin/redland-db-upgrade
-bin/roqet
include/librdf.h
-include/rasqal.h
include/rdf_concepts.h
include/rdf_digest.h
include/rdf_hash.h
include/rdf_init.h
include/rdf_iterator.h
+include/rdf_list.h
include/rdf_log.h
include/rdf_model.h
include/rdf_node.h
include/rdf_parser.h
include/rdf_query.h
+include/rdf_raptor.h
include/rdf_serializer.h
include/rdf_statement.h
include/rdf_storage.h
+include/rdf_storage_module.h
include/rdf_stream.h
include/rdf_uri.h
include/rdf_utf8.h
include/redland.h
-lib/librasqal.a
-lib/librasqal.la
-lib/librasqal.so
-lib/librasqal.so.0
lib/librdf.a
lib/librdf.la
lib/librdf.so
lib/librdf.so.0
-libdata/pkgconfig/rasqal.pc
+%%MYSQL%%lib/redland/librdf_storage_mysql.a
+%%MYSQL%%lib/redland/librdf_storage_mysql.la
+%%MYSQL%%lib/redland/librdf_storage_mysql.so
+%%PGSQL%%lib/redland/librdf_storage_postgresql.a
+%%PGSQL%%lib/redland/librdf_storage_postgresql.la
+%%PGSQL%%lib/redland/librdf_storage_postgresql.so
+%%SQLITE%%lib/redland/librdf_storage_sqlite.a
+%%SQLITE%%lib/redland/librdf_storage_sqlite.la
+%%SQLITE%%lib/redland/librdf_storage_sqlite.so
+%%VIRTUOSO%%lib/redland/librdf_storage_virtuoso.a
+%%VIRTUOSO%%lib/redland/librdf_storage_virtuoso.la
+%%VIRTUOSO%%lib/redland/librdf_storage_virtuoso.so
libdata/pkgconfig/redland.pc
-share/gtk-doc/html/rasqal/home.png
-share/gtk-doc/html/rasqal/index.html
-share/gtk-doc/html/rasqal/index.sgml
-share/gtk-doc/html/rasqal/ix01.html
-share/gtk-doc/html/rasqal/left.png
-share/gtk-doc/html/rasqal/pt01.html
-share/gtk-doc/html/rasqal/rasqal-section-data.html
-share/gtk-doc/html/rasqal/rasqal-section-expression.html
-share/gtk-doc/html/rasqal/rasqal-section-general.html
-share/gtk-doc/html/rasqal/rasqal-section-graph-pattern.html
-share/gtk-doc/html/rasqal/rasqal-section-literal.html
-share/gtk-doc/html/rasqal/rasqal-section-prefix.html
-share/gtk-doc/html/rasqal/rasqal-section-query-results.html
-share/gtk-doc/html/rasqal/rasqal-section-query.html
-share/gtk-doc/html/rasqal/rasqal-section-query-results-formatter.html
-share/gtk-doc/html/rasqal/rasqal-section-triple.html
-share/gtk-doc/html/rasqal/rasqal-section-triples-source.html
-share/gtk-doc/html/rasqal/rasqal-section-variable.html
-share/gtk-doc/html/rasqal/rasqal-section-xsd.html
-share/gtk-doc/html/rasqal/rasqal.devhelp
-share/gtk-doc/html/rasqal/rasqal.devhelp2
-share/gtk-doc/html/rasqal/rasqal.html
-share/gtk-doc/html/rasqal/right.png
-share/gtk-doc/html/rasqal/style.css
-share/gtk-doc/html/rasqal/up.png
share/gtk-doc/html/redland/home.png
share/gtk-doc/html/redland/index.html
share/gtk-doc/html/redland/index.sgml
@@ -88,6 +70,7 @@ share/gtk-doc/html/redland/redland-storage-module-postgresql.html
share/gtk-doc/html/redland/redland-storage-module-sqlite.html
share/gtk-doc/html/redland/redland-storage-module-tstore.html
share/gtk-doc/html/redland/redland-storage-module-uri.html
+share/gtk-doc/html/redland/redland-storage-module-virtuoso.html
share/gtk-doc/html/redland/redland-storage-modules.html
share/gtk-doc/html/redland/redland-stream.html
share/gtk-doc/html/redland/redland-unicode.html
@@ -99,6 +82,7 @@ share/gtk-doc/html/redland/redland.html
share/gtk-doc/html/redland/reference-manual.html
share/gtk-doc/html/redland/right.png
share/gtk-doc/html/redland/style.css
+share/gtk-doc/html/redland/tutorial-introduction.html
share/gtk-doc/html/redland/tutorial.html
share/gtk-doc/html/redland/up.png
%%MYSQL%%share/redland/mysql-v1.ttl
@@ -106,8 +90,6 @@ share/gtk-doc/html/redland/up.png
%%DATADIR%%/Redland.i
@dirrm lib/redland
@dirrm %%DATADIR%%
-@exec mkdir -p %D/share/gtk-doc/html/rasqal
-@dirrm share/gtk-doc/html/rasqal
@exec mkdir -p %D/share/gtk-doc/html/redland
@dirrm share/gtk-doc/html/redland
@dirrmtry share/gtk-doc