aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-08-17 08:12:13 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-08-17 08:12:13 +0000
commit5ee54264ce9df3e2f70ccf7e40858cd3547f12b9 (patch)
tree10db8be07ac397ff0b6183aecc3b697ae618d7c7 /textproc/redland
parent40bb79cd299825982888aff0c06173ff2dffe0de (diff)
Notes
Diffstat (limited to 'textproc/redland')
-rw-r--r--textproc/redland/Makefile32
-rw-r--r--textproc/redland/pkg-descr13
2 files changed, 27 insertions, 18 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 69d9e1b14b5a..6934f3a02ff0 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -8,35 +8,33 @@
PORTNAME= redland
PORTVERSION= 1.0.15
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://download.librdf.org/source/
MAINTAINER= kde@FreeBSD.org
-COMMENT= A high-level interface for RDF
+COMMENT= High-level interface for RDF
LIB_DEPENDS= raptor2.0:${PORTSDIR}/textproc/raptor2 \
rasqal.3:${PORTSDIR}/textproc/rasqal
-USE_BDB= yes
-WITH_BDB_HIGHEST= yes
-INVALID_BDB_VER=2
-USE_GNOME= gnomehack lthack pkgconfig libxml2
USE_AUTOTOOLS= libltdl
+USE_GNOME= gnomehack libxml2 lthack
USE_OPENSSL= yes
-USE_GMAKE= yes
+USE_PERL5_BUILD= yes
+USE_PKGCONFIG= both
GNU_CONFIGURE= yes
-
CONFIGURE_ARGS= --with-raptor=system \
--with-threestore=no
-
+USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5_BUILD= yes
MAN1= rdfproc.1 redland-config.1 \
redland-db-upgrade.1
MAN3= redland.3
-OPTIONS+= THREADS "Enable Threads" off
+OPTIONS_DEFINE= BDB THREADS
+OPTIONS_DEFAULT= BDB
# MYSQL "Use MySQL instead of BDB" off \
# PGSQL "Use PgSQL instead of BDB" off \
# SQLITE "Use SQLite instead of BDB" off \
@@ -44,10 +42,18 @@ OPTIONS+= THREADS "Enable Threads" off
.include <bsd.port.options.mk>
-.if defined(WITHOUT_THREADS)
-CONFIGURE_ARGS+= --disable-threads
+.if ${PORT_OPTIONS:MBDB}
+USE_BDB= yes
+WITH_BDB_HIGHEST= yes
+INVALID_BDB_VER= 2
.else
+CONFIGURE_ARGS+= --with-bdb=no
+.endif
+
+.if ${PORT_OPTIONS:MTHREADS}
CONFIGURE_ARGS+= --enable-threads
+.else
+CONFIGURE_ARGS+= --disable-threads
.endif
#.if defined(WITH_MYSQL)
@@ -90,8 +96,10 @@ PLIST_SUB+= VIRTUOSO="@comment "
#.endif
pre-everything::
+. if ${PORT_OPTIONS:MBDB}
@${ECHO_CMD} "You can choose BDB version by setting WITH_BDB_VER to one off:"
@${ECHO_CMD} "3 40 41 42 43 44 3+ 40+ 41+ 42+ 43+ 44+ (current: ${BDB_VER})"
+. endif
. if defined(WITH_MYSQL)
@${ECHO_CMD} "MySQL version to be used: ${MYSQL_VER}"
@${ECHO_CMD} "If you don't have MySQL installed you can stop the build now"
diff --git a/textproc/redland/pkg-descr b/textproc/redland/pkg-descr
index 022367271ed6..0153edd7e399 100644
--- a/textproc/redland/pkg-descr
+++ b/textproc/redland/pkg-descr
@@ -1,7 +1,8 @@
-Redland is a library that provides a high-level interface for RDF allowing
-the model to be stored, queried and manipulated. Redland implements each
-of the RDF model concepts in its own class so provides an object based API
-for them. Some of the classes providing the parsers, storage mechanisms and
-other elements are built as modules that can be added or removed as required.
+Redland is a set of libraries that provide a high-level interface for
+RDF allowing the model to be stored, queried and manipulated. Redland
+implements each of the RDF model concepts in its own class and
+provides an object based API for them. Some of the classes providing
+the parsers, storage mechanisms and other elements are built as
+modules that can be added or removed as required.
-WWW: http://librdf.org/
+WWW: http://librdf.org