aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-02 20:16:51 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-02 20:16:51 +0000
commite461462e97dcdd6f84c68151a7ed7702822db4e3 (patch)
treefda2754a7b6e9e4940b31ca941465bafa3df1517 /textproc/redland
parent0697fbeccbe49cba0295066a726986c4473cb60b (diff)
Notes
Diffstat (limited to 'textproc/redland')
-rw-r--r--textproc/redland/Makefile39
1 files changed, 8 insertions, 31 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 26a229fe3bb6..26d3b97f2f1e 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -3,6 +3,7 @@
PORTNAME= redland
PORTVERSION= 1.0.17
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://download.librdf.org/source/
@@ -18,39 +19,26 @@ LIB_DEPENDS= libraptor2.so:${PORTSDIR}/textproc/raptor2 \
librasqal.so:${PORTSDIR}/textproc/rasqal
USE_AUTOTOOLS= libltdl
-USE_GNOME= libxml2 lthack
-USE_OPENSSL= yes
USE_PERL5= build
USES= gmake pathfix perl5 pkgconfig shebangfix
SHEBANG_FILES= scripts/touch-mtime.pl
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-raptor=system \
- --with-threestore=no
+CONFIGURE_ARGS= --with-threestore=no
USE_LDCONFIG= yes
OPTIONS_DEFINE= BDB THREADS
OPTIONS_DEFAULT= BDB
+
+BDB_USE= BDB= yes
+BDB_CONFIGURE_OFF= --with-bdb=no
+
+THREADS_CONFIGURE_ENABLE= threads
+
# MYSQL "Use MySQL instead of BDB" off \
# PGSQL "Use PgSQL instead of BDB" off \
# SQLITE "Use SQLite instead of BDB" off \
# VIRTUOSO "Use Virtoso instead of BDB" off
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MBDB}
-USE_BDB= yes
-WITH_BDB_HIGHEST= yes
-INVALID_BDB_VER= 2
-.else
-CONFIGURE_ARGS+= --with-bdb=no
-.endif
-
-.if ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+= --enable-threads
-.else
-CONFIGURE_ARGS+= --disable-threads
-.endif
-
#.if defined(WITH_MYSQL)
#USE_MYSQL= yes
#CONFIGURE_ARGS+=--with-mysql=yes
@@ -90,15 +78,4 @@ CONFIGURE_ARGS+=--with-virtuoso=no
PLIST_SUB+= VIRTUOSO="@comment "
#.endif
-pre-everything::
-. if ${PORT_OPTIONS:MBDB}
- @${ECHO_CMD} "You can choose BDB version by setting WITH_BDB_VER to one off:"
- @${ECHO_CMD} "3 40 41 42 43 44 3+ 40+ 41+ 42+ 43+ 44+ (current: ${BDB_VER})"
-. endif
-. if defined(WITH_MYSQL)
- @${ECHO_CMD} "MySQL version to be used: ${MYSQL_VER}"
- @${ECHO_CMD} "If you don't have MySQL installed you can stop the build now"
- @${ECHO_CMD} "and set WITH_MYSQL_VER to the desired version"
-. endif
-
.include <bsd.port.mk>