aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-08 20:27:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-08 20:27:43 +0000
commit5252d83866730a322c09bd5a9a63cf396b3fe034 (patch)
treef7e29a8d7b2c8003ee158b4010b040fb0b857939 /textproc/redland
parenta6b98ac151e403bfc11c69ee4297c434222124b3 (diff)
downloadports-5252d83866730a322c09bd5a9a63cf396b3fe034.tar.gz
ports-5252d83866730a322c09bd5a9a63cf396b3fe034.zip
Notes
Diffstat (limited to 'textproc/redland')
-rw-r--r--textproc/redland/Makefile46
-rw-r--r--textproc/redland/distinfo4
2 files changed, 36 insertions, 14 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index 4bac8919c75a..bcf8f1a11de4 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -7,39 +7,61 @@
#
PORTNAME= redland
-PORTVERSION= 0.9.19
+PORTVERSION= 1.0.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://librdf.org/dist/source/
MASTER_SITE_SUBDIR= librdf
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= chuck@pkix.net
COMMENT= A high-level interface for RDF
-LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41 \
- raptor.2:${PORTSDIR}/textproc/raptor
+LIB_DEPENDS= raptor.2:${PORTSDIR}/textproc/raptor
+
+# Berkeley DB is also needed, default to using 4.2 if not set otherwise.
+WITH_BDB_VER?= 42
+.if ${WITH_BDB_VER} == 3
+LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
+.elif ${WITH_BDB_VER} == 4
+LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
+.elif ${WITH_BDB_VER} == 41
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
+.elif ${WITH_BDB_VER} == 42
+LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
+.else
+.error WITH_BDB_VER must be one of 3, 4, 41 and 42
+.endif
USE_GNOME= gnomehack gnometarget lthack pkgconfig
USE_OPENSSL= yes
USE_GETOPT_LONG= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER= 15
LIBTOOLFILES= configure raptor/configure rasqal/configure
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-bdb-lib="${LOCALBASE}/lib" \
- --with-bdb-include="${LOCALBASE}/include/db41" \
- --with-bdb-dbname="db41" \
+ --with-bdb-include="${LOCALBASE}/include/db${WITH_BDB_VER}" \
+ --with-bdb-dbname="db${WITH_BDB_VER}" \
--with-raptor=system \
--with-rasqal=internal \
- --with-threestore=no \
- --with-mysql=no
+ --with-threestore=no
+
+# optional use of recent MySQL versions
+.if defined(WANT_MYSQL_VER)
+.if ${WANT_MYSQL_VER} < 323
+ @${ECHO} "This port requires WANT_MYSQL_VER=323 or later to use MySQL."
+.else
+CONFIGURE_ARGS+=--with-mysql=yes
+.endif
+.endif
+
INSTALLS_SHLIB= yes
MAN1= rasqal-config.1 rdfproc.1 redland-config.1 \
redland-db-upgrade.1 roqet.1
MAN3= librasqal.3 redland.3
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
.include <bsd.port.mk>
diff --git a/textproc/redland/distinfo b/textproc/redland/distinfo
index 505e7bb6774b..9913cda11764 100644
--- a/textproc/redland/distinfo
+++ b/textproc/redland/distinfo
@@ -1,2 +1,2 @@
-MD5 (redland-0.9.19.tar.gz) = a9e413e5243e950e3322f6505481cedf
-SIZE (redland-0.9.19.tar.gz) = 2391325
+MD5 (redland-1.0.0.tar.gz) = 5fcfa0f0a2eac0cf23f0e916a3b29924
+SIZE (redland-1.0.0.tar.gz) = 2578757