aboutsummaryrefslogtreecommitdiff
path: root/textproc/rtfx
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-08-26 04:29:03 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-08-26 04:29:03 +0000
commit74f57da8f4ad28eb67bd7f878c22a8148f108d41 (patch)
treee0fa326cf84a48e7ad7c5c663df2e4a7c45c8d4f /textproc/rtfx
parent8b1f3b3b82bd69028b1360e87d90045d9d7c26d0 (diff)
downloadports-74f57da8f4ad28eb67bd7f878c22a8148f108d41.tar.gz
ports-74f57da8f4ad28eb67bd7f878c22a8148f108d41.zip
Notes
Diffstat (limited to 'textproc/rtfx')
-rw-r--r--textproc/rtfx/Makefile4
-rw-r--r--textproc/rtfx/files/extra-patch-src::reference.h-gcc34215
-rw-r--r--textproc/rtfx/files/extra-patch-src::sablo.h-gcc34215
3 files changed, 34 insertions, 0 deletions
diff --git a/textproc/rtfx/Makefile b/textproc/rtfx/Makefile
index b8e18814eda8..f486476051ff 100644
--- a/textproc/rtfx/Makefile
+++ b/textproc/rtfx/Makefile
@@ -28,5 +28,9 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src::domhelpers.h-gcc295
post-patch:
@${REINPLACE_CMD} -e "s/ //g" ${WRKSRC}/src/xmlcomposer.cpp
.endif
+.if ${OSVERSION} >= 502124
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src::reference.h-gcc342 \
+ ${FILESDIR}/extra-patch-src::sablo.h-gcc342
+.endif
.include <bsd.port.post.mk>
diff --git a/textproc/rtfx/files/extra-patch-src::reference.h-gcc342 b/textproc/rtfx/files/extra-patch-src::reference.h-gcc342
new file mode 100644
index 000000000000..bf185cd5dc7c
--- /dev/null
+++ b/textproc/rtfx/files/extra-patch-src::reference.h-gcc342
@@ -0,0 +1,15 @@
+--- src/reference.h.orig Fri Jul 23 05:03:03 2004
++++ src/reference.h Sat Aug 14 14:41:14 2004
+@@ -57,10 +57,10 @@
+ addref();
+ }
+
+- Reference(C* ptr, bool addref)
++ Reference(C* ptr, bool has_addref)
+ {
+ m_ptr = ptr;
+- if(addref)
++ if(has_addref)
+ addref();
+ }
+
diff --git a/textproc/rtfx/files/extra-patch-src::sablo.h-gcc342 b/textproc/rtfx/files/extra-patch-src::sablo.h-gcc342
new file mode 100644
index 000000000000..7d1148923b08
--- /dev/null
+++ b/textproc/rtfx/files/extra-patch-src::sablo.h-gcc342
@@ -0,0 +1,15 @@
+--- src/sablo.h.orig Sat Jul 24 12:18:06 2004
++++ src/sablo.h Sat Aug 14 14:42:45 2004
+@@ -146,10 +146,10 @@
+ addref();
+ }
+
+- Ref(C* ptr, bool addref)
++ Ref(C* ptr, bool has_addref)
+ {
+ m_ptr = ptr;
+- if(addref)
++ if(has_addref)
+ addref();
+ }
+