aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-amatch
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-09-14 16:34:27 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-09-14 16:34:27 +0000
commit259d0c73e85e3e5b27cd7a952368f8556e6333d0 (patch)
treeaa57a8b2a6368b40a8d5ef3c72fe7cb7c3b4c577 /textproc/ruby-amatch
parentc2884fae017cf41aa17f4dea9ef66a9f58b4f5b3 (diff)
Notes
Diffstat (limited to 'textproc/ruby-amatch')
-rw-r--r--textproc/ruby-amatch/Makefile29
-rw-r--r--textproc/ruby-amatch/pkg-descr2
2 files changed, 13 insertions, 18 deletions
diff --git a/textproc/ruby-amatch/Makefile b/textproc/ruby-amatch/Makefile
index 5c2f9f9c146a..c89fe10d9c94 100644
--- a/textproc/ruby-amatch/Makefile
+++ b/textproc/ruby-amatch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Ruby/amatch
-# Date created: 10 November 2002
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= amatch
PORTVERSION= 0.2.5
@@ -14,11 +10,13 @@ EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
-COMMENT= A Ruby library for approximate string matching and searching
+COMMENT= Ruby library for approximate string matching and searching
+
+OPTIONS_DEFINE= DOCS
-USE_RUBY= yes
-USE_GMAKE= yes
NO_BUILD= yes # build while install
+USE_RUBY= yes
+USES= gmake
PLIST_FILES= bin/agrep.rb %%RUBY_SITELIBDIR%%/amatch/version.rb \
%%RUBY_SITEARCHLIBDIR%%/amatch.so
@@ -28,17 +26,14 @@ AMATCH_RUBY= install.rb
DOCSDIR= ${RUBY_MODDOCDIR}
PORTDOCS= CHANGES README
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
do-install:
@${ECHO_MSG} "===> Running ${AMATCH_RUBY} to install"
- @cd ${INSTALL_WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${AMATCH_RUBY} install
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
-.endfor
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${AMATCH_RUBY} install
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/ruby-amatch/pkg-descr b/textproc/ruby-amatch/pkg-descr
index 5dba61c593b3..3717b7647256 100644
--- a/textproc/ruby-amatch/pkg-descr
+++ b/textproc/ruby-amatch/pkg-descr
@@ -2,4 +2,4 @@ This is a Ruby library for approximate string matching and searching
using a dynamic programming algorithm to compute the Levenstein
distance between strings. Written in C for speed.
-WWW: http://amatch.rubyforge.org/
+WWW: http://flori.github.io/amatch/