aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-diff
diff options
context:
space:
mode:
authorMakoto Matsushita <matusita@FreeBSD.org>2003-06-14 14:23:21 +0000
committerMakoto Matsushita <matusita@FreeBSD.org>2003-06-14 14:23:21 +0000
commit3548b99839d81918605e09228f20037a530c5ef3 (patch)
tree28eb5450450789733faad5d8410f67e2d17f7a88 /textproc/ruby-diff
parentd4937a2cbef29296b171a1d53b80de4ef69abf46 (diff)
downloadports-3548b99839d81918605e09228f20037a530c5ef3.tar.gz
ports-3548b99839d81918605e09228f20037a530c5ef3.zip
Notes
Diffstat (limited to 'textproc/ruby-diff')
-rw-r--r--textproc/ruby-diff/Makefile22
-rw-r--r--textproc/ruby-diff/distinfo1
-rw-r--r--textproc/ruby-diff/pkg-descr10
-rw-r--r--textproc/ruby-diff/pkg-plist2
4 files changed, 35 insertions, 0 deletions
diff --git a/textproc/ruby-diff/Makefile b/textproc/ruby-diff/Makefile
new file mode 100644
index 000000000000..8c0c22b82f3b
--- /dev/null
+++ b/textproc/ruby-diff/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: ruby-diff
+# Date created: 13 June 2003
+# Whom: Makoto Matsushita <matusita@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diff
+PORTVERSION= 0.4
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.rubynet.org/mirrors/diff/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= matusita@FreeBSD.org
+COMMENT= Ruby implementation of Perl's Algorithm::Diff
+
+USE_RUBY= YES
+USE_RUBY_SETUP= YES
+RUBY_SETUP= install.rb
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-diff/distinfo b/textproc/ruby-diff/distinfo
new file mode 100644
index 000000000000..36bee2b43325
--- /dev/null
+++ b/textproc/ruby-diff/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/diff-0.4.tar.gz) = 3e832de40dc1866dddc64978fe67e4c8
diff --git a/textproc/ruby-diff/pkg-descr b/textproc/ruby-diff/pkg-descr
new file mode 100644
index 000000000000..9385ea90271b
--- /dev/null
+++ b/textproc/ruby-diff/pkg-descr
@@ -0,0 +1,10 @@
+The diff algorithm computes the differences between two arrays of elements,
+like the unix program "diff". diff.rb is a Ruby conversion of the Perl's
+Algorithm::Diff. It can diff Arrays by each element or Strings by each
+character, or your own class if you implement the interface. The algorithm
+is complete, stable (TestUnit test available), but the interface may change
+before a 1.0 release.
+
+ -- excerpt from RAA (Ruby Application Archive)
+
+WWW: http://www.rubynet.org/mirrors/diff/
diff --git a/textproc/ruby-diff/pkg-plist b/textproc/ruby-diff/pkg-plist
new file mode 100644
index 000000000000..eff858dc7926
--- /dev/null
+++ b/textproc/ruby-diff/pkg-plist
@@ -0,0 +1,2 @@
+%%RUBY_SITELIBDIR%%/algorithm/diff.rb
+@dirrm %%RUBY_SITELIBDIR%%/algorithm