aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-erb/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-21 04:38:19 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-21 04:38:19 +0000
commit008ccef274d2fc41e5fdca210c7269ae1ef13348 (patch)
treefa81c31725f5e68c2c6f9e178bb40193ed390b2d /textproc/ruby-erb/Makefile
parentabbe92fc7c4f94cc68d34a8463f57eb43140a743 (diff)
Notes
Diffstat (limited to 'textproc/ruby-erb/Makefile')
-rw-r--r--textproc/ruby-erb/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/ruby-erb/Makefile b/textproc/ruby-erb/Makefile
new file mode 100644
index 000000000000..75a9b3873226
--- /dev/null
+++ b/textproc/ruby-erb/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby-ERb
+# Date created: 21 February 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= erb
+PORTVERSION= 1.3.3
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www2a.biglobe.ne.jp/~seki/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/sample/ja
+ ${MV} ${WRKSRC}/sample/sample.rhtml ${WRKSRC}/sample/ja
+
+post-patch:
+ ${RUBY} -i -pe '$$. == 1 and $$_ = "#!${RUBY}\n" + $$_' \
+ ${WRKSRC}/lib/erb/erb.rb
+
+do-install:
+ @cd ${WRKSRC}; \
+ ${RUBY} install.rb
+ ${LN} -s ${RUBY_SITELIBDIR}/erb/erb.rb ${PREFIX}/bin/erb
+.if !defined(NOPORTDOCS)
+ ${CP} -R ${WRKSRC}/sample ${RUBY_EXAMPLESDIR}/erb/
+.endif
+
+.include <bsd.port.mk>