aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-format/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-12-21 20:37:00 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-12-21 20:37:00 +0000
commite02467c37d5225db69f0ec268c1b2b221f49cbeb (patch)
tree3f782e6d37a149229b9ca710c6165e22f90a040a /textproc/ruby-format/Makefile
parent27a6fbeab4d6d900435e506cccd2db3bbaa4af5e (diff)
downloadports-e02467c37d5225db69f0ec268c1b2b221f49cbeb.tar.gz
ports-e02467c37d5225db69f0ec268c1b2b221f49cbeb.zip
Notes
Diffstat (limited to 'textproc/ruby-format/Makefile')
-rw-r--r--textproc/ruby-format/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/textproc/ruby-format/Makefile b/textproc/ruby-format/Makefile
index 21154eca715b..71a187397085 100644
--- a/textproc/ruby-format/Makefile
+++ b/textproc/ruby-format/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= format
-PORTVERSION= 0.93
+PORTVERSION= 1.02
CATEGORIES= textproc ruby
#MASTER_SITES= http://www.crhc.uiuc.edu/~rubel/
MASTER_SITES= ${MASTER_SITE_LOCAL}
@@ -18,24 +18,17 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
-
-NO_WRKSUBDIR= yes
-do-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD} format.rb > format.html
-.endif
+WRKSRC= ${WRKDIR}/FormatR
+NO_BUILD= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/format.rb ${RUBY_SITELIBDIR}/
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/test_format.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
- ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/format.html ${RUBY_DOCDIR}/${PORTNAME}/
+.for f in test_format.rb format_test.pl
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
.endif
.include <bsd.port.mk>