aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-html-fillinform/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-27 15:09:15 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-27 15:09:15 +0000
commit11e00240067cc93b9113e83bd27111aa7e20ff1d (patch)
tree32c0c0e3cefb9035e6d6636343c3c19f8e2a4ad7 /textproc/ruby-html-fillinform/Makefile
parent55c80788c166f5a424f632ae1a87071b20872349 (diff)
downloadports-11e00240067cc93b9113e83bd27111aa7e20ff1d.tar.gz
ports-11e00240067cc93b9113e83bd27111aa7e20ff1d.zip
Notes
Diffstat (limited to 'textproc/ruby-html-fillinform/Makefile')
-rw-r--r--textproc/ruby-html-fillinform/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/ruby-html-fillinform/Makefile b/textproc/ruby-html-fillinform/Makefile
new file mode 100644
index 000000000000..4e3614ccb537
--- /dev/null
+++ b/textproc/ruby-html-fillinform/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: HTML/FillInForm for Ruby
+# Date created: 27 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= html-fillinform
+PORTVERSION= 0.24
+CATEGORIES= textproc www ruby
+MASTER_SITES= http://shebang.jp/src/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby library that automatically inserts form data into HTML
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+DOCS_EN= ChangeLog \
+ README \
+ fillinform.rd
+DOCS_JA= fillinform.ja.rd
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/example/ ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>