aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-htmlrepair/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-09-20 05:05:29 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-09-20 05:05:29 +0000
commit370bf54aacabdc2ce1902c694907f1834f8ead2d (patch)
treecd95673738ff48e4584ff45e7d89ad8b1c3035e7 /textproc/ruby-htmlrepair/Makefile
parentd0bfc18a247bae9b8d2e1a948092614384030deb (diff)
downloadports-370bf54aacabdc2ce1902c694907f1834f8ead2d.tar.gz
ports-370bf54aacabdc2ce1902c694907f1834f8ead2d.zip
Notes
Diffstat (limited to 'textproc/ruby-htmlrepair/Makefile')
-rw-r--r--textproc/ruby-htmlrepair/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/ruby-htmlrepair/Makefile b/textproc/ruby-htmlrepair/Makefile
new file mode 100644
index 000000000000..ab1351a40bbf
--- /dev/null
+++ b/textproc/ruby-htmlrepair/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: htmlrepair.rb
+# Date created: 20 September 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlrepair
+PORTVERSION= 1.0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.moonwolf.com/ruby/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/htmlsplit.rb:${PORTSDIR}/textproc/ruby-htmlsplit
+
+USE_ZIP= yes
+USE_RUBY= yes
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/htmlrepair.rb ${RUBY_SITELIBDIR}/
+
+.include <bsd.port.mk>