aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-libxml/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:19:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-10 23:19:23 +0000
commit73465ff97581d9bb602ad82340bb928dc4e50d42 (patch)
tree9b6415f5ea4064f8557d25a00c57c7ede17e34ac /textproc/ruby-libxml/Makefile
parent177c93c8d5eb556727d8560f006d850128e53f20 (diff)
- Updates to 0.3.8.4
- Pass maintainship to submitter PR: 118938 Submitted by: Pietro Cerutti <gahr@gahr.ch>
Notes
Notes: svn path=/head/; revision=205428
Diffstat (limited to 'textproc/ruby-libxml/Makefile')
-rw-r--r--textproc/ruby-libxml/Makefile38
1 files changed, 23 insertions, 15 deletions
diff --git a/textproc/ruby-libxml/Makefile b/textproc/ruby-libxml/Makefile
index 4cc3ddae767f..ab1f8355da7c 100644
--- a/textproc/ruby-libxml/Makefile
+++ b/textproc/ruby-libxml/Makefile
@@ -6,30 +6,38 @@
#
PORTNAME= libxml
-PORTVERSION= 0.3.2
+PORTVERSION= 0.3.8.4
CATEGORIES= textproc ruby
-MASTER_SITES= http://www.rubynet.org/modules/xml/libxml/
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= libxml
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DIST_SUBDIR= ruby
+DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@gahr.ch
COMMENT= A friendly API to libxml for Ruby
-BUILD_DEPENDS= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
+ xml2-config:${PORTSDIR}/textproc/libxml2 \
+
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/xml/libxml.so
-PLIST_DIRS= %%RUBY_SITEARCHLIBDIR%%/xml
-USE_BZIP2= yes
+PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/xml/libxml_so.so \
+ %%RUBY_SITELIBDIR%%/xml/libxml.rb
+PLIST_DIRS= %%RUBY_SITEARCHLIBDIR%%/xml \
+ %%RUBY_SITELIBDIR%%/xml
+
USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
+USE_ICONV= yes
+USE_LDCONFIG= yes
-INSTALL_TARGET= site-install
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%%PREFIX%%%|${PREFIX}|g' \
+ ${WRKSRC}/ext/xml/extconf.rb
-.include <bsd.port.pre.mk>
+do-build:
+ cd ${WRKSRC} && rake test
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
+do-install:
+ cd ${WRKSRC} && rake install
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>