aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-libxml
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-07-15 17:25:00 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-07-15 17:25:00 +0000
commit0ec98a5ffe75219036bbcb0ca525eb7761482b64 (patch)
treebc395e372346b01e15f722a0f6d78a84bdad2736 /textproc/ruby-libxml
parent6c3440ddd0e8fdee28a0865fa73592d0fc99ff25 (diff)
downloadports-0ec98a5ffe75219036bbcb0ca525eb7761482b64.tar.gz
ports-0ec98a5ffe75219036bbcb0ca525eb7761482b64.zip
Notes
Diffstat (limited to 'textproc/ruby-libxml')
-rw-r--r--textproc/ruby-libxml/Makefile33
-rw-r--r--textproc/ruby-libxml/distinfo6
-rw-r--r--textproc/ruby-libxml/files/patch-ext-xml_extconf.rb11
3 files changed, 21 insertions, 29 deletions
diff --git a/textproc/ruby-libxml/Makefile b/textproc/ruby-libxml/Makefile
index c07fba72ed2e..5e6317c4e1c3 100644
--- a/textproc/ruby-libxml/Makefile
+++ b/textproc/ruby-libxml/Makefile
@@ -6,38 +6,41 @@
#
PORTNAME= libxml
-PORTVERSION= 0.5.2.0
+PORTVERSION= 0.7.0
CATEGORIES= textproc ruby
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= libxml
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-ruby-${PORTVERSION}
+EXTRACT_SUFX= .tgz
MAINTAINER= gahr@FreeBSD.org
COMMENT= A friendly API to libxml for Ruby
-BUILD_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
- xml2-config:${PORTSDIR}/textproc/libxml2 \
-
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/xml/libxml_so.so \
- %%RUBY_SITELIBDIR%%/xml/libxml.rb
-PLIST_DIRS= %%RUBY_SITEARCHLIBDIR%%/xml \
- %%RUBY_SITELIBDIR%%/xml
-
USE_RUBY= yes
USE_ICONV= yes
-USE_LDCONFIG= yes
+USE_LDCONFIG= ${RUBY_SITEARCHLIBDIR}/xml
+
+EXT_ARGS= --with-iconv-dir=${LOCALBASE} \
+ --with-iconv-lib=${LOCALBASE}/lib \
+ --with-iconv-include=${LOCALBASE}/include
+
+PLIST_FILES= %%RUBY_SITEARCHLIBDIR%%/xml/libxml.so \
+ %%RUBY_SITELIBDIR%%/xml/libxml.rb
+PLIST_DIRS= %%RUBY_SITEARCHLIBDIR%%/xml \
+ %%RUBY_SITELIBDIR%%/xml
-post-patch:
- ${REINPLACE_CMD} -e 's|%%%PREFIX%%%|${PREFIX}|g' \
- ${WRKSRC}/ext/xml/extconf.rb
+do-configure:
+ cd ${WRKSRC}/ext/libxml && ${RUBY} extconf.rb build ${EXT_ARGS}
do-build:
- cd ${WRKSRC} && rake test
+ cd ${WRKSRC}/ext/libxml && ${MAKE}
do-install:
- cd ${WRKSRC} && rake install
+ ${INSTALL} -d ${RUBY_SITELIBDIR}/xml ${RUBY_SITEARCHLIBDIR}/xml
+ ${INSTALL_DATA} ${WRKSRC}/lib/libxml.rb ${RUBY_SITELIBDIR}/xml
+ ${INSTALL_DATA} ${WRKSRC}/ext/libxml/libxml_ruby.so ${RUBY_SITEARCHLIBDIR}/xml/libxml.so
.include <bsd.port.mk>
diff --git a/textproc/ruby-libxml/distinfo b/textproc/ruby-libxml/distinfo
index ad715ea55527..31de6f214bd1 100644
--- a/textproc/ruby-libxml/distinfo
+++ b/textproc/ruby-libxml/distinfo
@@ -1,3 +1,3 @@
-MD5 (libxml-ruby-0.5.2.0.tar.gz) = 91ba2e2ae4a3d7ba9905f4495e54a714
-SHA256 (libxml-ruby-0.5.2.0.tar.gz) = 6c4103dce1c79ece1bc378426ee075357386a5cbd5633e9f1143e4d9cecfa534
-SIZE (libxml-ruby-0.5.2.0.tar.gz) = 69947
+MD5 (libxml-ruby-0.7.0.tgz) = 53fade7402afb18199976de443fda382
+SHA256 (libxml-ruby-0.7.0.tgz) = 3a27c8f51c3c92e224b99bc0ecef75ce77d4464cebebff7eb7b6b9352633d023
+SIZE (libxml-ruby-0.7.0.tgz) = 1356043
diff --git a/textproc/ruby-libxml/files/patch-ext-xml_extconf.rb b/textproc/ruby-libxml/files/patch-ext-xml_extconf.rb
deleted file mode 100644
index e932689e004d..000000000000
--- a/textproc/ruby-libxml/files/patch-ext-xml_extconf.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/xml/extconf.rb.orig 2006-10-20 13:37:49.000000000 +0200
-+++ ext/xml/extconf.rb 2007-12-21 21:01:31.000000000 +0100
-@@ -92,7 +92,7 @@
- $CFLAGS << ' -Wall'
- end
-
--$CFLAGS << ' ' << $INCFLAGS
-+$CFLAGS << ' ' << $INCFLAGS << ' ' << "-I /usr/local/include -L /usr/local/lib"
- $INSTALLFILES = [["libxml.rb", "$(RUBYLIBDIR)", "../xml"]]
-
- create_header()