aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-libxslt
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2002-10-24 19:01:12 +0000
committerSean Chittenden <seanc@FreeBSD.org>2002-10-24 19:01:12 +0000
commitdd3b25b365444a3b1b18f302f8f354ea4b0e394c (patch)
tree247e35a62026c9a98b8716be2f6037b6012e217c /textproc/ruby-libxslt
parent85daaf0b6f9fb3d205b6c1d1119c08cb52c31fb8 (diff)
downloadports-dd3b25b365444a3b1b18f302f8f354ea4b0e394c.tar.gz
ports-dd3b25b365444a3b1b18f302f8f354ea4b0e394c.zip
Notes
Diffstat (limited to 'textproc/ruby-libxslt')
-rw-r--r--textproc/ruby-libxslt/Makefile38
-rw-r--r--textproc/ruby-libxslt/distinfo2
-rw-r--r--textproc/ruby-libxslt/pkg-comment1
-rw-r--r--textproc/ruby-libxslt/pkg-descr6
-rw-r--r--textproc/ruby-libxslt/pkg-plist1
5 files changed, 48 insertions, 0 deletions
diff --git a/textproc/ruby-libxslt/Makefile b/textproc/ruby-libxslt/Makefile
new file mode 100644
index 000000000000..b953f3bf578f
--- /dev/null
+++ b/textproc/ruby-libxslt/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ruby-libxslt
+# Date created: 19 July 2002
+# Whom: Sean Chittenden <seanc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxslt
+PORTVERSION= 0.3.0
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.rubynet.org/modules/xml/libxslt/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= seanc@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2 \
+ ${LOCALBASE}/bin/xslt-config:${PORTSDIR}/textproc/libxslt \
+ ${NONEXISTENT}:${PORTSDIR}/${RUBY_LIBXML_PORT}:patch
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.1:${PORTSDIR}/textproc/libxslt
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/xml/libxml.so:${PORTSDIR}/textproc/ruby-libxml
+
+USE_BZIP2= yes
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+RUBY_LIBXML_PORT= textproc/ruby-libxml
+RUBY_LIBXML_WRKSRC_CMD= cd ${PORTSDIR}/${RUBY_LIBXML_PORT} && ${MAKE} -V WRKSRC
+
+INSTALL_TARGET= site-install
+
+post-extract:
+ @${MKDIR} ${WRKDIR}
+ @${LN} -fs `${RUBY_LIBXML_WRKSRC_CMD}` ${WRKDIR}/libxml
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-libxslt/distinfo b/textproc/ruby-libxslt/distinfo
new file mode 100644
index 000000000000..a1b05ea3ce4f
--- /dev/null
+++ b/textproc/ruby-libxslt/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/libxslt-0.3.0.tar.bz2) = c6f91999d17de183af188fb95b4c3510
+MD5 (ruby/libxml-0.3.0.tar.bz2) = ffa58d6e15cb8f1f84465267aa2837e8
diff --git a/textproc/ruby-libxslt/pkg-comment b/textproc/ruby-libxslt/pkg-comment
new file mode 100644
index 000000000000..821939a6e886
--- /dev/null
+++ b/textproc/ruby-libxslt/pkg-comment
@@ -0,0 +1 @@
+A developer friendly libxslt binding for Ruby
diff --git a/textproc/ruby-libxslt/pkg-descr b/textproc/ruby-libxslt/pkg-descr
new file mode 100644
index 000000000000..62e228ae6e5d
--- /dev/null
+++ b/textproc/ruby-libxslt/pkg-descr
@@ -0,0 +1,6 @@
+ruby-libxslt provies an interface into the libxslt library, a
+feature complete XSLT library.
+
+Author: Sean Chittenden <sean@chittenden.org>
+
+WWW: http://www.rubynet.org/modules/xml/libxslt/
diff --git a/textproc/ruby-libxslt/pkg-plist b/textproc/ruby-libxslt/pkg-plist
new file mode 100644
index 000000000000..bda78aef963b
--- /dev/null
+++ b/textproc/ruby-libxslt/pkg-plist
@@ -0,0 +1 @@
+%%RUBY_SITEARCHLIBDIR%%/xml/libxslt.so