aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-mwdom/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-22 08:52:13 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-22 08:52:13 +0000
commitd7b0547a079fa2a90479a4c9a446443827a59090 (patch)
treeb8510c9c0d7b6019c2bd9d4c3799b7114bc875bc /textproc/ruby-mwdom/Makefile
parentc21967f445f87775df65c7e727f6b26ec8e6ba99 (diff)
downloadports-d7b0547a079fa2a90479a4c9a446443827a59090.tar.gz
ports-d7b0547a079fa2a90479a4c9a446443827a59090.zip
Notes
Diffstat (limited to 'textproc/ruby-mwdom/Makefile')
-rw-r--r--textproc/ruby-mwdom/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/ruby-mwdom/Makefile b/textproc/ruby-mwdom/Makefile
new file mode 100644
index 000000000000..6256b1c5e76d
--- /dev/null
+++ b/textproc/ruby-mwdom/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Ruby/MWDOM
+# Date created: 22 August 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mwdom
+PORTVERSION= 0.1.5
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.moonwolf.com/ruby/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/xpathtree.rb:${PORTSDIR}/textproc/ruby-xmlscan
+
+USE_BZIP2= yes
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+do-install:
+ ${CP} -R ${WRKSRC}/mwdom ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/*.* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>