aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-raspell
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-10 17:40:10 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-10 17:40:10 +0000
commit1cc520232fd05c2a43b076aa65d939a284617992 (patch)
tree2135d316fdd46272ad7b3d38f17b37e7df593113 /textproc/ruby-raspell
parentf66b7b2e41e7850d743ddf94aa096847ca7b2f13 (diff)
downloadports-1cc520232fd05c2a43b076aa65d939a284617992.tar.gz
ports-1cc520232fd05c2a43b076aa65d939a284617992.zip
Notes
Diffstat (limited to 'textproc/ruby-raspell')
-rw-r--r--textproc/ruby-raspell/Makefile34
-rw-r--r--textproc/ruby-raspell/distinfo1
-rw-r--r--textproc/ruby-raspell/pkg-comment1
-rw-r--r--textproc/ruby-raspell/pkg-descr5
-rw-r--r--textproc/ruby-raspell/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/textproc/ruby-raspell/Makefile b/textproc/ruby-raspell/Makefile
new file mode 100644
index 000000000000..aa2c83e3ac9c
--- /dev/null
+++ b/textproc/ruby-raspell/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: rAspell
+# Date created: 10 November 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= raspell
+PORTVERSION= 0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= aspell.15:${PORTSDIR}/textproc/aspell
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.rb ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-raspell/distinfo b/textproc/ruby-raspell/distinfo
new file mode 100644
index 000000000000..6f82cc046c22
--- /dev/null
+++ b/textproc/ruby-raspell/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/raspell-0.1.tgz) = 650a054ac70367cff874343ed3e0b4c1
diff --git a/textproc/ruby-raspell/pkg-comment b/textproc/ruby-raspell/pkg-comment
new file mode 100644
index 000000000000..59c882475e27
--- /dev/null
+++ b/textproc/ruby-raspell/pkg-comment
@@ -0,0 +1 @@
+A Ruby interface binding to aspell
diff --git a/textproc/ruby-raspell/pkg-descr b/textproc/ruby-raspell/pkg-descr
new file mode 100644
index 000000000000..5bfef73fd19f
--- /dev/null
+++ b/textproc/ruby-raspell/pkg-descr
@@ -0,0 +1,5 @@
+rAspell is an interface binding to aspell (http://aspell.net).
+Aspell is a very comfortable spell checker.
+
+Author: Matthias Veit <matthias_veit@yahoo.de>
+WWW: http://sourceforge.net/projects/raspell/
diff --git a/textproc/ruby-raspell/pkg-plist b/textproc/ruby-raspell/pkg-plist
new file mode 100644
index 000000000000..7fd761ea28f0
--- /dev/null
+++ b/textproc/ruby-raspell/pkg-plist
@@ -0,0 +1,5 @@
+%%RUBY_SITEARCHLIBDIR%%/raspell.so
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/example.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%