aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-rttool
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2010-10-06 12:42:24 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2010-10-06 12:42:24 +0000
commit6dfc57c1556738ca7d921be93cc0916a8970c48c (patch)
tree83136de2ac5566db6abdc6d32bbb1c16ae10bff0 /textproc/ruby-rttool
parent66f2e7164b6db0faf40369fe659d91d84ea767a7 (diff)
downloadports-6dfc57c1556738ca7d921be93cc0916a8970c48c.tar.gz
ports-6dfc57c1556738ca7d921be93cc0916a8970c48c.zip
Notes
Diffstat (limited to 'textproc/ruby-rttool')
-rw-r--r--textproc/ruby-rttool/Makefile44
-rw-r--r--textproc/ruby-rttool/distinfo3
-rw-r--r--textproc/ruby-rttool/pkg-descr8
-rw-r--r--textproc/ruby-rttool/pkg-plist26
4 files changed, 81 insertions, 0 deletions
diff --git a/textproc/ruby-rttool/Makefile b/textproc/ruby-rttool/Makefile
new file mode 100644
index 000000000000..20865f4da8a5
--- /dev/null
+++ b/textproc/ruby-rttool/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ruby-rttool
+# Date created: 2010-10-04
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rttool
+PORTVERSION= 1.0.3
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.rubyist.net/~rubikitch/archive/ \
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|tota/ruby-rttool|}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ${RUBY_PKGNAMEPREFIX:S|${RUBY_SUFFIX}-||}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= RT into HTML and plain text converter
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+USE_RUBY_RDTOOL= yes
+
+RUBY_SHEBANG_FILES= bin/rt/* lib/rt/*
+RUBY_MODNAME= rt
+
+DOCS_EN= rttool.en.html rttool.en.rd
+DOCS_JA= rttool.ja.html rttool.ja.rd
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${RUBY_MODEXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-rttool/distinfo b/textproc/ruby-rttool/distinfo
new file mode 100644
index 000000000000..f37f567ac029
--- /dev/null
+++ b/textproc/ruby-rttool/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/rttool-1.0.3.tar.gz) = e2eecf5ea3ff0c51b74c22327733765d
+SHA256 (ruby/rttool-1.0.3.tar.gz) = f8d38370f61dfc1c8ff5c1b3bc3807f6a47499d31463a285fbc0a68163bb4aa5
+SIZE (ruby/rttool-1.0.3.tar.gz) = 36895
diff --git a/textproc/ruby-rttool/pkg-descr b/textproc/ruby-rttool/pkg-descr
new file mode 100644
index 000000000000..e16d32180f44
--- /dev/null
+++ b/textproc/ruby-rttool/pkg-descr
@@ -0,0 +1,8 @@
+RT is a simple and human-readable table format.
+RTtool is a converter from RT into various formats.
+RT can be incorporated into RD.
+
+At this time, RTtool can convert RT into HTML and plain text.
+To convert into plain text, you need w3m.
+
+WWW: http://www.rubyist.net/~rubikitch/computer/rttool/index.en.html
diff --git a/textproc/ruby-rttool/pkg-plist b/textproc/ruby-rttool/pkg-plist
new file mode 100644
index 000000000000..ce25a80392a2
--- /dev/null
+++ b/textproc/ruby-rttool/pkg-plist
@@ -0,0 +1,26 @@
+bin/rdrt2
+bin/rt2
+%%RUBY_SITELIBDIR%%/rd/rt-filter.rb
+%%RUBY_SITELIBDIR%%/rt/rt2html-lib.rb
+%%RUBY_SITELIBDIR%%/rt/rt2txt-lib.rb
+%%RUBY_SITELIBDIR%%/rt/rtparser.rb
+%%RUBY_SITELIBDIR%%/rt/rtvisitor.rb
+%%RUBY_SITELIBDIR%%/rt/w3m.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rttool.en.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/rttool.en.rd
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/rttool.ja.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/rttool.ja.rd
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/easiest.html
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/easiest.rt
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/escape.html
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/escape.rt
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/rttest.html
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/rttest.rd
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test1.html
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test1.rt
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test2.html
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test2.rt
+%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+@dirrm %%RUBY_SITELIBDIR%%/rt