aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-sablot/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-06-24 18:02:38 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-06-24 18:02:38 +0000
commit129b7f43c4e8ffe4db20dffa9480e753ffc01dd6 (patch)
treeab9d30891ceeb62e620b34c6ad91c876617ef188 /textproc/ruby-sablot/Makefile
parent85df8a48dc430adc6e1a4ef6ec14ec887b77c8ea (diff)
Notes
Diffstat (limited to 'textproc/ruby-sablot/Makefile')
-rw-r--r--textproc/ruby-sablot/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/textproc/ruby-sablot/Makefile b/textproc/ruby-sablot/Makefile
index 2b090c5b3e08..c864702dfd6a 100644
--- a/textproc/ruby-sablot/Makefile
+++ b/textproc/ruby-sablot/Makefile
@@ -6,36 +6,32 @@
#
PORTNAME= sablot
-PORTVERSION= 0.4.0
-PORTREVISION= 2
+PORTVERSION= 0.5.0
CATEGORIES= textproc ruby
-MASTER_SITES= http://www.inac.co.jp/~maki/ruby/
+MASTER_SITES= http://www.rubycolor.org/arc/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-LIB_DEPENDS= sablot.60:${PORTSDIR}/textproc/sablotron
+LIB_DEPENDS= sablot.60:${PORTSDIR}/textproc/sablotron \
+ iconv.2:${PORTSDIR}/converters/iconv \
+ expat.2:${PORTSDIR}/textproc/expat2
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-.if !defined(NOPORTDOCS)
-USE_RUBY_RD= yes
-.endif
+CONFIGURE_ARGS= --with-sablot-lib="${LOCALBASE}" \
+ --with-iconv="${LOCALBASE}" \
+ --with-expat="${LOCALBASE}"
INSTALL_TARGET= site-install
-DOCS= README sablot.html sablot.rd
-
-post-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${RUBY_RD} sablot.rd > sablot.html
-.endif
+DOCS= README doc/*
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${CP} -R ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/