aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-sablot/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-10-07 07:14:01 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-10-07 07:14:01 +0000
commit5588ac433c5e16198a83ba26b7f493b385d15f55 (patch)
tree4ad8e4e93a3097c1c7a7d33134c0c1fda6abcbcc /textproc/ruby-sablot/Makefile
parentfd751f1110fd8f1ed5b6e0a9e2056019d281a4ef (diff)
downloadports-5588ac433c5e16198a83ba26b7f493b385d15f55.tar.gz
ports-5588ac433c5e16198a83ba26b7f493b385d15f55.zip
Notes
Diffstat (limited to 'textproc/ruby-sablot/Makefile')
-rw-r--r--textproc/ruby-sablot/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/textproc/ruby-sablot/Makefile b/textproc/ruby-sablot/Makefile
index 5476bd3c52cb..8c579500fbb3 100644
--- a/textproc/ruby-sablot/Makefile
+++ b/textproc/ruby-sablot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sablot
-PORTVERSION= 0.5.0
-PORTREVISION= 2
+PORTVERSION= 0.5.2
CATEGORIES= textproc ruby
MASTER_SITES= http://www.rubycolor.org/arc/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -27,16 +26,23 @@ CONFIGURE_ARGS= --with-sablot-lib="${LOCALBASE}" \
--with-expat="${LOCALBASE}"
INSTALL_TARGET= site-install
-DOCS= README doc/*
+DOCS_EN= README \
+ doc/sablot.html \
+ doc/sablot.rd
+DOCS_JA= doc/sablot_ja.html \
+ doc/sablot.rd.ja
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
${CP} -R ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
- ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
-.for f in ${DOCS}
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
.endif
.include <bsd.port.mk>