aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-sablot/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-09 16:08:49 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-09 16:08:49 +0000
commit59a3efc65c72ba88922676669c8b3968ce5ec743 (patch)
tree0a102421faf41090073ae39009d90cf139f1bd94 /textproc/ruby-sablot/Makefile
parent83606be0140980ab6c152726855222db746b7e90 (diff)
downloadports-59a3efc65c72ba88922676669c8b3968ce5ec743.tar.gz
ports-59a3efc65c72ba88922676669c8b3968ce5ec743.zip
Notes
Diffstat (limited to 'textproc/ruby-sablot/Makefile')
-rw-r--r--textproc/ruby-sablot/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/textproc/ruby-sablot/Makefile b/textproc/ruby-sablot/Makefile
new file mode 100644
index 000000000000..b02b97def7c2
--- /dev/null
+++ b/textproc/ruby-sablot/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: Ruby-sablot
+# Date created: 9 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sablot
+PORTVERSION= 0.0.2
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.inac.co.jp/~maki/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= sablot.51:${PORTSDIR}/textproc/sablotron
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+.if !defined(NOPORTDOCS)
+USE_RUBY_RD= yes
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+DOCS= README sablot.html sablot.rd
+
+post-extract:
+ ${RM} ${WRKSRC}/Makefile
+
+post-build:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${RUBY_RD} sablot.rd > sablot.html
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>