aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-sablot
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-09 16:08:49 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-09 16:08:49 +0000
commit59a3efc65c72ba88922676669c8b3968ce5ec743 (patch)
tree0a102421faf41090073ae39009d90cf139f1bd94 /textproc/ruby-sablot
parent83606be0140980ab6c152726855222db746b7e90 (diff)
downloadports-59a3efc65c72ba88922676669c8b3968ce5ec743.tar.gz
ports-59a3efc65c72ba88922676669c8b3968ce5ec743.zip
Notes
Diffstat (limited to 'textproc/ruby-sablot')
-rw-r--r--textproc/ruby-sablot/Makefile48
-rw-r--r--textproc/ruby-sablot/distinfo1
-rw-r--r--textproc/ruby-sablot/files/patch-extconf.rb18
-rw-r--r--textproc/ruby-sablot/pkg-comment1
-rw-r--r--textproc/ruby-sablot/pkg-descr8
-rw-r--r--textproc/ruby-sablot/pkg-plist10
6 files changed, 86 insertions, 0 deletions
diff --git a/textproc/ruby-sablot/Makefile b/textproc/ruby-sablot/Makefile
new file mode 100644
index 000000000000..b02b97def7c2
--- /dev/null
+++ b/textproc/ruby-sablot/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: Ruby-sablot
+# Date created: 9 March 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sablot
+PORTVERSION= 0.0.2
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.inac.co.jp/~maki/ruby/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= sablot.51:${PORTSDIR}/textproc/sablotron
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+.if !defined(NOPORTDOCS)
+USE_RUBY_RD= yes
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+DOCS= README sablot.html sablot.rd
+
+post-extract:
+ ${RM} ${WRKSRC}/Makefile
+
+post-build:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${RUBY_RD} sablot.rd > sablot.html
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-sablot/distinfo b/textproc/ruby-sablot/distinfo
new file mode 100644
index 000000000000..f03997fbe89b
--- /dev/null
+++ b/textproc/ruby-sablot/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/sablot-0.0.2.tar.gz) = 077cefea47d357cf17dfc0c0d5691d52
diff --git a/textproc/ruby-sablot/files/patch-extconf.rb b/textproc/ruby-sablot/files/patch-extconf.rb
new file mode 100644
index 000000000000..23f7e51ff5a8
--- /dev/null
+++ b/textproc/ruby-sablot/files/patch-extconf.rb
@@ -0,0 +1,18 @@
+--- extconf.rb.orig Sun Dec 3 23:50:31 2000
++++ extconf.rb Sat Mar 10 00:35:37 2001
+@@ -2,10 +2,10 @@
+
+ dir_config('sablot')
+
+-$LOCAL_LIBS += " -L/usr/local/lib -lsablot -lxmlparse -lxmltok"
+-
+-if have_header("sablot.h") &&
+- have_library("sablot", "SablotProcessStrings") &&
+- have_library("xmltok", "XML_ParserCreate")
++if have_header("expat.h") &&
++ have_header("sablot.h") &&
++ have_library("expat", "XML_ParserCreate") &&
++ have_library("iconv") &&
++ have_library("sablot", "SablotProcessStrings")
+ create_makefile("sablot")
+ end
diff --git a/textproc/ruby-sablot/pkg-comment b/textproc/ruby-sablot/pkg-comment
new file mode 100644
index 000000000000..4a18318b79a0
--- /dev/null
+++ b/textproc/ruby-sablot/pkg-comment
@@ -0,0 +1 @@
+Ruby interface to the Sablotron XSLT processor
diff --git a/textproc/ruby-sablot/pkg-descr b/textproc/ruby-sablot/pkg-descr
new file mode 100644
index 000000000000..c875af12a579
--- /dev/null
+++ b/textproc/ruby-sablot/pkg-descr
@@ -0,0 +1,8 @@
+This is the experimental version of a Ruby interface to Sablotron, the
+XSLT processor developed by Ginger Alliance.
+
+This module's license is the combination of MPL (Mozilla Public
+License) and GPL.
+
+Author: TAKAHASHI Masayoshi <maki@inac.co.jp>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=sablot
diff --git a/textproc/ruby-sablot/pkg-plist b/textproc/ruby-sablot/pkg-plist
new file mode 100644
index 000000000000..c00d7b0ca155
--- /dev/null
+++ b/textproc/ruby-sablot/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITEARCHLIBDIR%%/sablot.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/sablot/sample.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/sablot/sample.xml
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/sablot/sample.xsl
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/sablot/sample2.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/sablot
+%%PORTDOCS%%%%RUBY_DOCDIR%%/sablot/README
+%%PORTDOCS%%%%RUBY_DOCDIR%%/sablot/sablot.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/sablot/sablot.rd
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/sablot