aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-xml-script
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-09-15 08:17:11 +0000
commitc5aeb93cd5e4998728da54611bdf63c686a2fdfd (patch)
treef418d7aa01e7bae10fc4d0734eec45cd9e925529 /textproc/ruby-xml-script
parentf4c5a682e5c43c1c1477307463458409ae3b3de5 (diff)
downloadports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.tar.gz
ports-c5aeb93cd5e4998728da54611bdf63c686a2fdfd.zip
Notes
Diffstat (limited to 'textproc/ruby-xml-script')
-rw-r--r--textproc/ruby-xml-script/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/textproc/ruby-xml-script/Makefile b/textproc/ruby-xml-script/Makefile
index 087554cf8bfd..bca691dcb596 100644
--- a/textproc/ruby-xml-script/Makefile
+++ b/textproc/ruby-xml-script/Makefile
@@ -16,9 +16,10 @@ DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= A Ruby module for scripting an XML stream using an ASP-like notation
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/js.so:${PORTSDIR}/lang/ruby-js \
- ${RUBY_SITEARCHLIBDIR}/lua.so:${PORTSDIR}/lang/ruby-lua4
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/js.so:${PORTSDIR}/lang/ruby-js
+USE_LUA= 4.0
+LUA_COMPS= ruby
USE_RUBY= yes
USE_RUBY_SETUP= yes
@@ -28,6 +29,10 @@ DOCS= AUTHORS \
README
EXAMPLES= tests/*
+post-patch:
+ @${REINPLACE_CMD} -Ee 's|(language/lua)|\1-${LUA_VER}|' \
+ ${WRKSRC}/lib/xml/script/lua/compiler.rb
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}