aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-xslt/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-22 08:40:33 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-22 08:40:33 +0000
commitc21967f445f87775df65c7e727f6b26ec8e6ba99 (patch)
tree8e8fd01cf58fd735d90adfb61a567b1d3405b6cf /textproc/ruby-xslt/Makefile
parent187a8be20c563339d8ae06059b3c8505bb2b5bcf (diff)
downloadports-c21967f445f87775df65c7e727f6b26ec8e6ba99.tar.gz
ports-c21967f445f87775df65c7e727f6b26ec8e6ba99.zip
Notes
Diffstat (limited to 'textproc/ruby-xslt/Makefile')
-rw-r--r--textproc/ruby-xslt/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/ruby-xslt/Makefile b/textproc/ruby-xslt/Makefile
new file mode 100644
index 000000000000..f953478976cd
--- /dev/null
+++ b/textproc/ruby-xslt/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ruby-xmlscan
+# Date created: 22 August 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xslt
+PORTVERSION= 0.0.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.fantasy-coders.de/ruby/xslt4r/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}4r-${PORTVERSION:S/./_/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/xpathtree.rb:${PORTSDIR}/textproc/ruby-xmlscan
+
+USE_RUBY= yes
+
+RUBY_SHEBANG_FILES= ${WRKSRC}/xslt.rb
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xslt.rb ${RUBY_SITELIBDIR}/
+ ${LN} -sf ${RUBY_SITELIBDIR}/xslt.rb ${LOCALBASE}/bin/xslt
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/test/*.x* ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/ToDo ${RUBY_DOCDIR}/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>