aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-xslt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-19 13:58:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-19 13:58:38 +0000
commit60055c62e0433edb43f5d9d6962b1f9badac295b (patch)
tree9c285816b48576f9f45172cc529fceb0e886f0c0 /textproc/ruby-xslt
parent7a6f7df4c60a51dae7ae475433dd8022a476be54 (diff)
downloadports-60055c62e0433edb43f5d9d6962b1f9badac295b.tar.gz
ports-60055c62e0433edb43f5d9d6962b1f9badac295b.zip
Notes
Diffstat (limited to 'textproc/ruby-xslt')
-rw-r--r--textproc/ruby-xslt/Makefile9
-rw-r--r--textproc/ruby-xslt/distinfo6
-rw-r--r--textproc/ruby-xslt/files/patch-extfunc.h11
3 files changed, 10 insertions, 16 deletions
diff --git a/textproc/ruby-xslt/Makefile b/textproc/ruby-xslt/Makefile
index e86e21e4e6e9..0d60031dd565 100644
--- a/textproc/ruby-xslt/Makefile
+++ b/textproc/ruby-xslt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xslt
-PORTVERSION= 0.8.1
+PORTVERSION= 0.8.2
CATEGORIES= textproc ruby
MASTER_SITES= http://gregoire.lejeune.free.fr/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -22,10 +22,15 @@ USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
+.include <bsd.port.pre.mk>
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
.endif
-.include <bsd.port.mk>
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/ruby-xslt/distinfo b/textproc/ruby-xslt/distinfo
index 9cf6f72d44e3..e05dfef86d56 100644
--- a/textproc/ruby-xslt/distinfo
+++ b/textproc/ruby-xslt/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/ruby-xslt_0.8.1.tar.gz) = 28cc6a296564178c890ae202ba9aaccf
-SHA256 (ruby/ruby-xslt_0.8.1.tar.gz) = b7e989e711ee3322676358fe228945bb9dce8cb880fdb58b24b95b4687b4ae81
-SIZE (ruby/ruby-xslt_0.8.1.tar.gz) = 21189
+MD5 (ruby/ruby-xslt_0.8.2.tar.gz) = 603615dd4f31fe0981aff7b1bee2a0a6
+SHA256 (ruby/ruby-xslt_0.8.2.tar.gz) = 7e7b8c4fdd4f9e4e414e9817ba8e32fea032204902eb2f1f6b9468df081d07a1
+SIZE (ruby/ruby-xslt_0.8.2.tar.gz) = 23566
diff --git a/textproc/ruby-xslt/files/patch-extfunc.h b/textproc/ruby-xslt/files/patch-extfunc.h
deleted file mode 100644
index 30400f6986ee..000000000000
--- a/textproc/ruby-xslt/files/patch-extfunc.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- extfunc.h.orig Mon Mar 28 21:48:01 2005
-+++ extfunc.h Tue Aug 9 17:04:58 2005
-@@ -21,7 +21,7 @@
- /* this stores function names and the ids of the objects they belong to, indexed by name and namespace */
- static xmlHashTablePtr pExtFunctionsHashTable = NULL;
-
--void deallocateCallback( void *, xmlChar * ATTRIBUTE_UNUSED );
-+void deallocateCallback( void *payload, xmlChar *name ATTRIBUTE_UNUSED );
- VALUE xpathObj2value( xmlXPathObjectPtr, xmlDocPtr );
- xmlXPathObjectPtr value2xpathObj( VALUE );
- void xmlXPathFuncCallback( xmlXPathParserContextPtr, int );