aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-xtemplate
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-07-06 12:34:08 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-07-06 12:34:08 +0000
commitc05e6d24302d831f0878a06d086a409ed0697cf6 (patch)
tree6e3cabf2d2d73befcef36f7abf09246516abcaf8 /textproc/ruby-xtemplate
parent5db0a7fbc07eb813348e2c328f72399f8a7e9578 (diff)
downloadports-c05e6d24302d831f0878a06d086a409ed0697cf6.tar.gz
ports-c05e6d24302d831f0878a06d086a409ed0697cf6.zip
Notes
Diffstat (limited to 'textproc/ruby-xtemplate')
-rw-r--r--textproc/ruby-xtemplate/Makefile4
-rw-r--r--textproc/ruby-xtemplate/files/patch-xt.c16
2 files changed, 16 insertions, 4 deletions
diff --git a/textproc/ruby-xtemplate/Makefile b/textproc/ruby-xtemplate/Makefile
index c3f55ed3e231..1fabf749ccf2 100644
--- a/textproc/ruby-xtemplate/Makefile
+++ b/textproc/ruby-xtemplate/Makefile
@@ -28,10 +28,6 @@ DOCS_EN= CHANGES README STATUS TUTORIAL
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
diff --git a/textproc/ruby-xtemplate/files/patch-xt.c b/textproc/ruby-xtemplate/files/patch-xt.c
new file mode 100644
index 000000000000..14071ec9317e
--- /dev/null
+++ b/textproc/ruby-xtemplate/files/patch-xt.c
@@ -0,0 +1,16 @@
+--- ext/xt.c.orig Wed May 30 19:05:12 2007
++++ ext/xt.c Wed May 30 19:07:43 2007
+@@ -243,11 +243,12 @@
+ return rb_funcall(children, i_collect, 0);
+ }
+
++static VALUE rb_xt_xnode_deep_dup(int, VALUE[], VALUE);
++
+ static VALUE
+ rb_xt_xnode_deep_dup_ii(VALUE child, VALUE data)
+ {
+ VALUE node = data;
+- static VALUE rb_xt_xnode_deep_dup(int, VALUE[], VALUE);
+
+ if( rb_obj_is_kind_of(child, rb_cXNode) ){
+ VALUE argv[1] = {node};