aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-escape_utils-rails4
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-27 15:52:54 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-27 15:52:54 +0000
commite8b8297427fa7cba18cddd0d765cfd3d34c81e02 (patch)
tree5d54767d113e3124e9fe6fbc9f004c8b97310991 /textproc/rubygem-escape_utils-rails4
parent6fe245206927fed97201bc6338d118c34d38c311 (diff)
downloadports-e8b8297427fa7cba18cddd0d765cfd3d34c81e02.tar.gz
ports-e8b8297427fa7cba18cddd0d765cfd3d34c81e02.zip
Notes
Diffstat (limited to 'textproc/rubygem-escape_utils-rails4')
-rw-r--r--textproc/rubygem-escape_utils-rails4/Makefile27
-rw-r--r--textproc/rubygem-escape_utils-rails4/distinfo2
-rw-r--r--textproc/rubygem-escape_utils-rails4/pkg-descr14
3 files changed, 43 insertions, 0 deletions
diff --git a/textproc/rubygem-escape_utils-rails4/Makefile b/textproc/rubygem-escape_utils-rails4/Makefile
new file mode 100644
index 000000000000..968ffe2471da
--- /dev/null
+++ b/textproc/rubygem-escape_utils-rails4/Makefile
@@ -0,0 +1,27 @@
+# Created by: Scott Sanders <scott@jssjr.com>
+# $FreeBSD$
+
+PORTNAME= escape_utils
+PORTVERSION= 1.0.1
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= -rails4
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Faster string escaping routines for your web apps
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-actionpack4>=0:${PORTSDIR}/www/rubygem-actionpack4 \
+ rubygem-fast_xs>=0:${PORTSDIR}/textproc/rubygem-fast_xs \
+ rubygem-haml>=0:${PORTSDIR}/www/rubygem-haml \
+ rubygem-minitest>=5:${PORTSDIR}/devel/rubygem-minitest \
+ rubygem-rack>=0:${PORTSDIR}/www/rubygem-rack \
+ rubygem-rake-compiler>=0.7.5:${PORTSDIR}/devel/rubygem-rake-compiler \
+ rubygem-url_escape>=0:${PORTSDIR}/www/rubygem-url_escape
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-escape_utils-rails4/distinfo b/textproc/rubygem-escape_utils-rails4/distinfo
new file mode 100644
index 000000000000..a0edddc86afc
--- /dev/null
+++ b/textproc/rubygem-escape_utils-rails4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/escape_utils-1.0.1.gem) = 669467df9a8dae259211f5afb5be9dff88879d855af14afee2b5778bf6530960
+SIZE (rubygem/escape_utils-1.0.1.gem) = 25600
diff --git a/textproc/rubygem-escape_utils-rails4/pkg-descr b/textproc/rubygem-escape_utils-rails4/pkg-descr
new file mode 100644
index 000000000000..1d7667b43bd2
--- /dev/null
+++ b/textproc/rubygem-escape_utils-rails4/pkg-descr
@@ -0,0 +1,14 @@
+Async (EventMachine) HTTP client, with support for:
+o Asynchronous HTTP API for single & parallel request execution
+o Keep-Alive and HTTP pipelining support
+o Auto-follow 3xx redirects with max depth
+o Automatic gzip & deflate decoding
+o Streaming response processing
+o Streaming file uploads
+o HTTP proxy and SOCKS5 support
+o Basic Auth & OAuth
+o Connection-level & Global middleware support
+o HTTP parser via http_parser.rb
+o Works wherever EventMachine runs: Rubinius, JRuby, MRI
+
+WWW: https://github.com/brianmario/escape_utils