aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-escape_utils
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2011-12-16 22:22:45 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2011-12-16 22:22:45 +0000
commit66f31bdae79ee667d8e3e58f5cace3a86369482e (patch)
tree0b449a7d6fe5fa9313633eef16601529f06c6cf6 /textproc/rubygem-escape_utils
parent2e72d7901ced1c27d95cac071790fd88b35981ec (diff)
downloadports-66f31bdae79ee667d8e3e58f5cace3a86369482e.tar.gz
ports-66f31bdae79ee667d8e3e58f5cace3a86369482e.zip
Async (EventMachine) HTTP client, with support for:
o Asynchronous HTTP API for single & parallel request execution o Keep-Alive and HTTP pipelining support o Auto-follow 3xx redirects with max depth o Automatic gzip & deflate decoding o Streaming response processing o Streaming file uploads o HTTP proxy and SOCKS5 support o Basic Auth & OAuth o Connection-level & Global middleware support o HTTP parser via http_parser.rb o Works wherever EventMachine runs: Rubinius, JRuby, MRI WWW: https://github.com/igrigorik/em-http-request PR: ports/163361 Submitted by: Scott Sanders <scott@jssjr.com> Sponsored by: RideCharge Inc. / Taxi Magic
Notes
Notes: svn path=/head/; revision=287507
Diffstat (limited to 'textproc/rubygem-escape_utils')
-rw-r--r--textproc/rubygem-escape_utils/Makefile28
-rw-r--r--textproc/rubygem-escape_utils/distinfo2
-rw-r--r--textproc/rubygem-escape_utils/pkg-descr14
3 files changed, 44 insertions, 0 deletions
diff --git a/textproc/rubygem-escape_utils/Makefile b/textproc/rubygem-escape_utils/Makefile
new file mode 100644
index 000000000000..b346897b4273
--- /dev/null
+++ b/textproc/rubygem-escape_utils/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: rubygem-escape_utils
+# Date created: 13 Dec 2011
+# Whom: Scott Sanders <scott@jssjr.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= escape_utils
+PORTVERSION= 0.2.4
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Faster string escaping routines for your web apps
+
+RUN_DEPENDS= rubygem-actionpack>=0:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-fast_xs>=0:${PORTSDIR}/textproc/rubygem-fast_xs \
+ rubygem-haml>=0:${PORTSDIR}/www/rubygem-haml \
+ rubygem-rack>=0:${PORTSDIR}/www/rubygem-rack \
+ rubygem-rake-compiler>=0.7.5:${PORTSDIR}/devel/rubygem-rake-compiler \
+ rubygem-rspec>=2.0.0:${PORTSDIR}/devel/rubygem-rspec \
+ rubygem-url_escape>=0:${PORTSDIR}/www/rubygem-url_escape
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-escape_utils/distinfo b/textproc/rubygem-escape_utils/distinfo
new file mode 100644
index 000000000000..4f63995860bd
--- /dev/null
+++ b/textproc/rubygem-escape_utils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/escape_utils-0.2.4.gem) = 8f14b54e78845b9673d4ade8ec7f748652e18e19cd9800605f810ba0d4bbe555
+SIZE (rubygem/escape_utils-0.2.4.gem) = 23040
diff --git a/textproc/rubygem-escape_utils/pkg-descr b/textproc/rubygem-escape_utils/pkg-descr
new file mode 100644
index 000000000000..df7ad52e3ceb
--- /dev/null
+++ b/textproc/rubygem-escape_utils/pkg-descr
@@ -0,0 +1,14 @@
+Async (EventMachine) HTTP client, with support for:
+o Asynchronous HTTP API for single & parallel request execution
+o Keep-Alive and HTTP pipelining support
+o Auto-follow 3xx redirects with max depth
+o Automatic gzip & deflate decoding
+o Streaming response processing
+o Streaming file uploads
+o HTTP proxy and SOCKS5 support
+o Basic Auth & OAuth
+o Connection-level & Global middleware support
+o HTTP parser via http_parser.rb
+o Works wherever EventMachine runs: Rubinius, JRuby, MRI
+
+WWW: https://github.com/igrigorik/em-http-request