aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-html-pipeline-gitlab
diff options
context:
space:
mode:
authorMichael Moll <mmoll@FreeBSD.org>2015-05-13 00:45:28 +0000
committerMichael Moll <mmoll@FreeBSD.org>2015-05-13 00:45:28 +0000
commit0aa4b78c9207d74b29e94b6c34f0c65077e402a7 (patch)
treee06ab9c44db7b3cc55dc24b357ec8dc3fe5f81bd /textproc/rubygem-html-pipeline-gitlab
parent9ee92eb13856faa8896605a78a50eacccd159975 (diff)
downloadports-0aa4b78c9207d74b29e94b6c34f0c65077e402a7.tar.gz
ports-0aa4b78c9207d74b29e94b6c34f0c65077e402a7.zip
Notes
Diffstat (limited to 'textproc/rubygem-html-pipeline-gitlab')
-rw-r--r--textproc/rubygem-html-pipeline-gitlab/Makefile24
-rw-r--r--textproc/rubygem-html-pipeline-gitlab/distinfo2
-rw-r--r--textproc/rubygem-html-pipeline-gitlab/files/patch-html-pipeline-gitlab.gemspec11
-rw-r--r--textproc/rubygem-html-pipeline-gitlab/pkg-descr3
4 files changed, 40 insertions, 0 deletions
diff --git a/textproc/rubygem-html-pipeline-gitlab/Makefile b/textproc/rubygem-html-pipeline-gitlab/Makefile
new file mode 100644
index 000000000000..829e9722c06b
--- /dev/null
+++ b/textproc/rubygem-html-pipeline-gitlab/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= html-pipeline-gitlab
+PORTVERSION= 0.2.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Extension filters for html-pipeline used by GitLab
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-actionpack4>=4:${PORTSDIR}/www/rubygem-actionpack4 \
+ rubygem-gitlab_emoji>=0.1.0:${PORTSDIR}/graphics/rubygem-gitlab_emoji \
+ rubygem-html-pipeline>=1.11.0:${PORTSDIR}/textproc/rubygem-html-pipeline \
+ rubygem-mime-types>0:${PORTSDIR}/misc/rubygem-mime-types \
+ rubygem-sanitize>=2.1:${PORTSDIR}/textproc/rubygem-sanitize
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-html-pipeline-gitlab/distinfo b/textproc/rubygem-html-pipeline-gitlab/distinfo
new file mode 100644
index 000000000000..81cddb0050a9
--- /dev/null
+++ b/textproc/rubygem-html-pipeline-gitlab/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/html-pipeline-gitlab-0.2.0.gem) = 3631eedbf33ff56eda6a6ee898277fe47f188377c19e55b20d4eac8f95208448
+SIZE (rubygem/html-pipeline-gitlab-0.2.0.gem) = 9216
diff --git a/textproc/rubygem-html-pipeline-gitlab/files/patch-html-pipeline-gitlab.gemspec b/textproc/rubygem-html-pipeline-gitlab/files/patch-html-pipeline-gitlab.gemspec
new file mode 100644
index 000000000000..abe6a52e9ac0
--- /dev/null
+++ b/textproc/rubygem-html-pipeline-gitlab/files/patch-html-pipeline-gitlab.gemspec
@@ -0,0 +1,11 @@
+--- html-pipeline-gitlab.gemspec.orig 2015-05-12 18:41:42 UTC
++++ html-pipeline-gitlab.gemspec
+@@ -27,7 +27,7 @@ Gem::Specification.new do |s|
+ s.add_development_dependency(%q<pry>, ["~> 0.9"])
+ s.add_runtime_dependency(%q<html-pipeline>, ["~> 1.11.0"])
+ s.add_runtime_dependency(%q<gitlab_emoji>, ["~> 0.1"])
+- s.add_runtime_dependency(%q<sanitize>, ["~> 2.1"])
++ s.add_runtime_dependency(%q<sanitize>, [">= 2.1"])
+ s.add_runtime_dependency(%q<actionpack>, ["~> 4"])
+ s.add_runtime_dependency(%q<mime-types>, [">= 0"])
+ else
diff --git a/textproc/rubygem-html-pipeline-gitlab/pkg-descr b/textproc/rubygem-html-pipeline-gitlab/pkg-descr
new file mode 100644
index 000000000000..3a8bd63a1894
--- /dev/null
+++ b/textproc/rubygem-html-pipeline-gitlab/pkg-descr
@@ -0,0 +1,3 @@
+This gem contains extension filters for html-pipeline used by GitLab.
+
+WWW: https://gitlab.com/gitlab-org/html-pipeline-gitlab