aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-nokogiri
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-18 21:01:16 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-18 21:01:16 +0000
commitc6923fb5be2f5002423d03b5e2ce6da5b54b9ba1 (patch)
tree5807c3c3251ef84f79be98756c217500d5896dbe /textproc/rubygem-nokogiri
parent9310ff0064bcc9199725a60d1d801e7d2c61b916 (diff)
downloadports-c6923fb5be2f5002423d03b5e2ce6da5b54b9ba1.tar.gz
ports-c6923fb5be2f5002423d03b5e2ce6da5b54b9ba1.zip
Notes
Diffstat (limited to 'textproc/rubygem-nokogiri')
-rw-r--r--textproc/rubygem-nokogiri/Makefile24
-rw-r--r--textproc/rubygem-nokogiri/distinfo3
-rw-r--r--textproc/rubygem-nokogiri/pkg-descr9
3 files changed, 36 insertions, 0 deletions
diff --git a/textproc/rubygem-nokogiri/Makefile b/textproc/rubygem-nokogiri/Makefile
new file mode 100644
index 000000000000..80401d3539b2
--- /dev/null
+++ b/textproc/rubygem-nokogiri/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: rubygem-nokogiri
+# Date created: 17 May 2009
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= nokogiri
+PORTVERSION= 1.2.3
+CATEGORIES= textproc rubygems
+MASTER_SITES= RF
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= An HTML, XML, SAX, and Reader parser
+
+BUILD_DEPENDS= ${RUBY_PKGNAMEPREFIX}iconv>=0:${PORTSDIR}/converters/ruby-iconv
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GNOME= libxml2 libxslt
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-nokogiri/distinfo b/textproc/rubygem-nokogiri/distinfo
new file mode 100644
index 000000000000..24fb2dae8172
--- /dev/null
+++ b/textproc/rubygem-nokogiri/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/nokogiri-1.2.3.gem) = 4654239b8deb597a905a722a1854911c
+SHA256 (rubygem/nokogiri-1.2.3.gem) = f8b4c06e0abe0b8d18585604354c919554ab909bf19c0913e44e2e6d744cabe7
+SIZE (rubygem/nokogiri-1.2.3.gem) = 247808
diff --git a/textproc/rubygem-nokogiri/pkg-descr b/textproc/rubygem-nokogiri/pkg-descr
new file mode 100644
index 000000000000..f3abed221973
--- /dev/null
+++ b/textproc/rubygem-nokogiri/pkg-descr
@@ -0,0 +1,9 @@
+* XPath support for document searching
+* CSS3 selector support for document searching
+* XML/HTML builder
+* Drop in replacement for Hpricot (though not bug for bug)
+
+Nokogiri parses and searches XML/HTML very quickly, and also has
+correctly implemented CSS3 selector support as well as XPath support.
+
+WWW: http://nokogiri.rubyforge.org/nokogiri/