aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-rails-dom-testing
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2015-06-10 18:09:37 +0000
committerSteve Wills <swills@FreeBSD.org>2015-06-10 18:09:37 +0000
commit83c258ba8a2d1d7c88323024241939a97f1d1005 (patch)
treefa06780ae18b5bcabe5f40aece52218c20f993f4 /textproc/rubygem-rails-dom-testing
parent68d04a0b91a805d0a1cebb7f8b6be23ba2115d43 (diff)
downloadports-83c258ba8a2d1d7c88323024241939a97f1d1005.tar.gz
ports-83c258ba8a2d1d7c88323024241939a97f1d1005.zip
Notes
Diffstat (limited to 'textproc/rubygem-rails-dom-testing')
-rw-r--r--textproc/rubygem-rails-dom-testing/Makefile22
-rw-r--r--textproc/rubygem-rails-dom-testing/distinfo2
-rw-r--r--textproc/rubygem-rails-dom-testing/pkg-descr8
3 files changed, 32 insertions, 0 deletions
diff --git a/textproc/rubygem-rails-dom-testing/Makefile b/textproc/rubygem-rails-dom-testing/Makefile
new file mode 100644
index 000000000000..97edfad5df2b
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Jost Meixner <xmj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rails-dom-testing
+PORTVERSION= 1.0.6
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Analyse and compare DOMs using Nokogiri
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-activesupport4>=${PORTVERSION}:${PORTSDIR}/devel/rubygem-activesupport4 \
+ rubygem-nokogiri>1.6:${PORTSDIR}/textproc/rubygem-nokogiri \
+ rubygem-rails-deprecated_sanitizer>1.0:${PORTSDIR}/devel/rubygem-rails-deprecated_sanitizer
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-rails-dom-testing/distinfo b/textproc/rubygem-rails-dom-testing/distinfo
new file mode 100644
index 000000000000..31a7cf95f469
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rails-dom-testing-1.0.6.gem) = a7b69cc95c84b5eb8e3fc6cd77726e409475415223c298647b61ffa33d849dd7
+SIZE (rubygem/rails-dom-testing-1.0.6.gem) = 17408
diff --git a/textproc/rubygem-rails-dom-testing/pkg-descr b/textproc/rubygem-rails-dom-testing/pkg-descr
new file mode 100644
index 000000000000..c87a1ba37065
--- /dev/null
+++ b/textproc/rubygem-rails-dom-testing/pkg-descr
@@ -0,0 +1,8 @@
+This gem is responsible for comparing HTML doms and asserting that DOM elements
+are present in Rails applications. Doms are compared via assert_dom_equal and
+assert_dom_not_equal. Elements are asserted via assert_select,
+assert_select_encoded, assert_select_email and a subset of the dom can be
+selected with css_select. The gem is developed for Rails 4.2 and above, and
+will not work on previous versions.
+
+WWW: https://github.com/rails/rails-dom-testing