aboutsummaryrefslogtreecommitdiff
path: root/textproc/rubygem-syntax/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-04-07 10:54:51 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-04-07 10:54:51 +0000
commit3804046c6f596e205738146c34d299829d149cbb (patch)
tree6e3b86e5200b9dd9e59bf5be606ec961b14d32a8 /textproc/rubygem-syntax/Makefile
parent76180713b709187d95a54c62d9ef75aa04b4bbba (diff)
- switch to repaired gemfile
Notes
Notes: svn path=/head/; revision=210723
Diffstat (limited to 'textproc/rubygem-syntax/Makefile')
-rw-r--r--textproc/rubygem-syntax/Makefile49
1 files changed, 3 insertions, 46 deletions
diff --git a/textproc/rubygem-syntax/Makefile b/textproc/rubygem-syntax/Makefile
index 6a0376b5055b..09fdee0a4298 100644
--- a/textproc/rubygem-syntax/Makefile
+++ b/textproc/rubygem-syntax/Makefile
@@ -6,58 +6,15 @@
PORTNAME= syntax
PORTVERSION= 1.0.0
+PKGVERSION= 1
CATEGORIES= textproc rubygems
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-PKGNAMEPREFIX= rubygem-
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A module for using Systax highlighting in Ruby
USE_RUBY= yes
+USE_RUBYGEMS= yes
-.include <bsd.port.pre.mk>
-#.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-# syntax.gem has invalid content, we need to buuild the gem ourself
-
-.if ${RUBY_VER} == 1.8
-BUILD_DEPENDS+= ${RUBYGEMBIN}:${PORTSDIR}/devel/ruby-gems
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-.endif
-
-REV= ${RUBY_VER}
-GEMS_BASE_DIR= lib/ruby/gems/${REV}
-GEMS_DIR= ${GEMS_BASE_DIR}/gems
-DOC_DIR= ${GEMS_BASE_DIR}/doc
-CACHE_DIR= ${GEMS_BASE_DIR}/cache
-SPEC_DIR= ${GEMS_BASE_DIR}/specifications
-GEM_NAME?= ${PORTNAME}-${PORTVERSION}
-GEM_LIB_DIR= ${GEMS_DIR}/${GEM_NAME}
-GEM_DOC_DIR= ${DOC_DIR}/${GEM_NAME}
-GEM_SPEC= ${SPEC_DIR}/${GEM_NAME}.gemspec
-GEM_CACHE= ${CACHE_DIR}/${GEM_NAME}.gem
-
-PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
- REV="${REV}" \
- GEMS_BASE_DIR="lib/ruby/gems/${REV}" \
- GEMS_DIR="${GEMS_BASE_DIR}/gems" \
- DOC_DIR="${GEMS_BASE_DIR}/doc" \
- CACHE_DIR="${GEMS_BASE_DIR}/cache" \
- SPEC_DIR="${GEMS_BASE_DIR}/specifications" \
- PORT="${PORTNAME}-${PORTVERSION}" \
- GEM_NAME="${GEM_NAME}" \
- GEM_LIB_DIR="${GEM_LIB_DIR}" \
- GEM_DOC_DIR="${GEM_DOC_DIR}" \
- GEM_SPEC="${GEM_SPEC}" \
- GEM_CACHE="${GEM_CACHE}" \
- EXTRACT_SUFX="${EXTRACT_SUFX}"
-
-RUBYGEMBIN= ${LOCALBASE}/bin/gem${RUBY_VER:S/.//}
-
-do-build:
- cd ${WRKSRC} && ${RUBYGEMBIN} build syntax.gemspec
-
-do-install:
- ${RUBYGEMBIN} install --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.gem
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>