aboutsummaryrefslogtreecommitdiff
path: root/textproc/sablotron/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-20 09:08:32 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-20 09:08:32 +0000
commitad08a5b5a95466efd64d46d7f2931684565027b7 (patch)
tree026f1b7dd815c45feef83ce6e9c2891deabdf71f /textproc/sablotron/Makefile
parent7e75ef19100638a5740c19c209e3764d14b3da6f (diff)
downloadports-ad08a5b5a95466efd64d46d7f2931684565027b7.tar.gz
ports-ad08a5b5a95466efd64d46d7f2931684565027b7.zip
Notes
Diffstat (limited to 'textproc/sablotron/Makefile')
-rw-r--r--textproc/sablotron/Makefile67
1 files changed, 37 insertions, 30 deletions
diff --git a/textproc/sablotron/Makefile b/textproc/sablotron/Makefile
index 51beb0d3d989..049af653e0cd 100644
--- a/textproc/sablotron/Makefile
+++ b/textproc/sablotron/Makefile
@@ -9,46 +9,53 @@ MASTER_SITES= SF/sablotron/sablotron-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= XML toolkit implementing XSLT 1.0, XPath 1.0 and DOM Level2
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LICENSE= GPLv2
+
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+
+OPTIONS_DEFINE= CHECK_LEAKS DEBUGGER DISABLE_META DOCS \
+ DOCUMENT_ERRORS DOM ICONV_TYPECAST
-OPTIONS_DEFINE= DISABLE_META ICONV_TYPECAST DOM DOCUMENT_ERRORS CHECK_LEAKS DEBUGGER DOCS
-DISABLE_META_DESC= Do not output the META html tag
-ICONV_TYPECAST_DESC= Use iconv typecast
-DOM_DESC= Use DOM
-DOCUMENT_ERRORS_DESC= Allow document errors
CHECK_LEAKS_DESC= Enable memory leaks checking
DEBUGGER_DESC= Enable debugger
+DISABLE_META_DESC= Do not output the META html tag
+DOCUMENT_ERRORS_DESC= Allow document errors
+DOM_DESC= Use DOM
+ICONV_TYPECAST_DESC= Use iconv typecast
+
OPTIONS_DEFAULT= DOM DOCUMENT_ERRORS
-DISABLE_META_CONFIGURE_ON= --disable-adding-meta
-ICONV_TYPECAST_CONFIGURE_ENABLE= iconv-typecast
-DOM_CONFIGURE_ENABLE= dom
+CHECK_LEAKS_CONFIGURE_ENABLE= check-leaks
+DEBUGGER_CONFIGURE_ENABLE= debugger
+DISABLE_META_CONFIGURE_ON= --disable-adding-meta
+DOCS_BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+DOCS_CONFIGURE_ON= --with-html-dir=${DOCSDIR}
+DOM_CONFIGURE_ENABLE= dom
DOCUMENT_ERRORS_CONFIGURE_ENABLE= document-errors
-CHECK_LEAKS_CONFIGURE_ENABLE= check-leaks
-DEBUGGER_CONFIGURE_ENABLE= debugger
-DOCS_BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-DOCS_CONFIGURE_ON= --with-html-dir=${DOCSDIR}
-
-USE_LDCONFIG= yes
+ICONV_TYPECAST_CONFIGURE_ENABLE= iconv-typecast
SHLIB_MAJOR= 70 # API changes counter
PLIST_SUB+= SHLIB_MAJOR="${SHLIB_MAJOR}"
-CONFIGURE_ENV= LIBTOOL=${LIBTOOL}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lexpat ${ICONV_LIB}
+USES= gmake iconv perl5
+USE_PERL5= build patch
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
-USES= iconv perl5
GNU_CONFIGURE= yes
-USE_PERL5= build patch
+CONFIGURE_ENV= LIBTOOL=${LIBTOOL}
+USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include -w
+LDFLAGS+= -L${LOCALBASE}/lib -lexpat ${ICONV_LIB}
+
+PORTDOCS= *
-MAN1= sabcmd.1
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= README README_JS RELEASE
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+DOCSRCDIR2= ${WRKSRC}/doc/misc
+DOCSDIR2= ${DOCSDIR}/doc/misc
+DOC_FILES2= DEBUGGER NOTES
-DOCSLIST= README README_JS RELEASE doc/misc/DEBUGGER doc/misc/NOTES
+.include <bsd.port.options.mk>
post-patch:
@${PERL} -pi -e \
@@ -60,9 +67,9 @@ post-patch:
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${ECHO_MSG} "===> Installing additional documentation for ${PKGNAME}"
- @${INSTALL_DATA} ${DOCSLIST:S!^!${WRKSRC}/!} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>