aboutsummaryrefslogtreecommitdiff
path: root/textproc/sagasu/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 06:28:17 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 06:28:17 +0000
commitee6006cb9341cd57f54b23cb84ddad08dca74f6e (patch)
tree3aabf9f3857bcbb632cc1fa37c00868b8f01c5a1 /textproc/sagasu/Makefile
parent86607a29b5c4f7aedd210a2c69431084ab79e5fb (diff)
Notes
Diffstat (limited to 'textproc/sagasu/Makefile')
-rw-r--r--textproc/sagasu/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/sagasu/Makefile b/textproc/sagasu/Makefile
new file mode 100644
index 000000000000..0084d65573b8
--- /dev/null
+++ b/textproc/sagasu/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/sagasu
+# Date created: 10 Jul 2003
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+
+PORTNAME= sagasu
+PORTVERSION= 2.0.3
+CATEGORIES= textproc gnome
+MASTER_SITES= http://www3.sympatico.ca/sarrazip/dev/
+
+MAINTAINER= rael@vectorstar.net
+COMMENT= Sagasu is a GNOME tool to find strings in a set of files
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= sagasu.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ;' ${WRKSRC}/configure
+
+.include <bsd.port.mk>