aboutsummaryrefslogtreecommitdiff
path: root/textproc/sagasu/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-17 20:27:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-17 20:27:45 +0000
commit631b8fd5c1e0f42cb41ff90671be98267232b4f9 (patch)
tree06bdfc34f58875aea0805071e94d7eefb47eb916 /textproc/sagasu/Makefile
parentbe4376de7577c35dcc655431b3e9c8ffc07fa770 (diff)
downloadports-631b8fd5c1e0f42cb41ff90671be98267232b4f9.tar.gz
ports-631b8fd5c1e0f42cb41ff90671be98267232b4f9.zip
Notes
Diffstat (limited to 'textproc/sagasu/Makefile')
-rw-r--r--textproc/sagasu/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/textproc/sagasu/Makefile b/textproc/sagasu/Makefile
index 889a354a7690..76ec3c42ffce 100644
--- a/textproc/sagasu/Makefile
+++ b/textproc/sagasu/Makefile
@@ -5,29 +5,36 @@
# $FreeBSD$
PORTNAME= sagasu
-PORTVERSION= 2.0.6
-PORTREVISION= 3
+PORTVERSION= 2.0.7
CATEGORIES= textproc gnome
MASTER_SITES= http://www3.sympatico.ca/sarrazip/dev/ \
http://demian.dyndns.org/src/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Sagasu is a GNOME tool to find strings in a set of files
+COMMENT= A GNOME tool to find strings in a set of files
USE_X_PREFIX= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
-USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= sagasu.1
post-patch:
- @${REINPLACE_CMD} -e 's|[(]datadir[)]/doc/$$(PACKAGE)-$$(VERSION)|(prefix)/share/doc/$$(PACKAGE)|g' \
- ${WRKSRC}/Makefile.in
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-D.*_DISABLE_DEPRECATED||g'
+ @${REINPLACE_CMD} -e \
+ 's|: install-docDATA|:|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-D.*_DISABLE_DEPRECATED||g' ${WRKSRC}/src/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS INSTALL NEWS README THANKS TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>