aboutsummaryrefslogtreecommitdiff
path: root/textproc/saxon-devel/Makefile
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-03-22 10:46:17 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-03-22 10:46:17 +0000
commita55a53397fcf7051b9d366665abae12c897fa86e (patch)
tree887ebe4a057b4fc7e6d8c4dfa959237f4b933441 /textproc/saxon-devel/Makefile
parentf3e5234550c058a8bc48ed4daf6eead88404413c (diff)
downloadports-a55a53397fcf7051b9d366665abae12c897fa86e.tar.gz
ports-a55a53397fcf7051b9d366665abae12c897fa86e.zip
Notes
Diffstat (limited to 'textproc/saxon-devel/Makefile')
-rw-r--r--textproc/saxon-devel/Makefile24
1 files changed, 20 insertions, 4 deletions
diff --git a/textproc/saxon-devel/Makefile b/textproc/saxon-devel/Makefile
index c4b7b083765b..5fc9f017641f 100644
--- a/textproc/saxon-devel/Makefile
+++ b/textproc/saxon-devel/Makefile
@@ -6,19 +6,23 @@
#
PORTNAME= saxon
-PORTVERSION= 8.6.1
+PORTVERSION= 8.7
PORTEPOCH= 1
CATEGORIES= textproc java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= saxon
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}b${PORTVERSION:S,.,-,g}
+DISTNAME= ${PORTNAME}b${PORTVERSION:S,.,-,g}j \
+ ${PORTNAME}-resources${PORTVERSION:S,.,-,g}
MAINTAINER= hq@FreeBSD.org
COMMENT= An XSLT 2.0 / XPath 2.0 / XQuery 1.0 processor for Java
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
+OPTIONS= JDOM "Install Jdom support" off \
+ XOM "Install XOM support" off
+
USE_ZIP= yes
USE_JAVA= yes
JAVA_VERSION= 1.4+
@@ -27,12 +31,24 @@ NO_BUILD= yes
CONFLICTS= saxon-6.*
-JARFILES= saxon8-sql.jar saxon8.jar
+JARFILES= saxon8-sql.jar saxon8.jar saxon8-xpath.jar saxon8-dom.jar
PLIST_FILES+= ${JARFILES:S,^,%%JAVAJARDIR%%/,} bin/saxon bin/saxon-xquery
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_JDOM)
+JARFILES+= saxon8-jdom.jar
+RUN_DEPENDS+= ${JAVALIBDIR}/jdom.jar:${PORTSDIR}/java/jdom
+.endif
+
+.if defined(WITH_XOM)
+JARFILES+= saxon8-xom.jar
+RUN_DEPENDS+= ${JAVALIBDIR}/xom.jar:${PORTSDIR}/textproc/xom
+.endif
+
SUB_FILES= saxon.sh
SUB_LIST= SAXON_JARS="${JARFILES:S,^,${JAVAJARDIR}/,}"
@@ -71,4 +87,4 @@ post-install:
${SED} -ne 's,^${WRKSRC}/samples,@dirrm ${EXAMPLESDIR:S,${PREFIX}/,,},p' >> ${TMPPLIST}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>