aboutsummaryrefslogtreecommitdiff
path: root/textproc/saxon
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:50:40 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-04 22:50:40 +0000
commit5fad809a5036ede0aa1484f20794ae259980b7fa (patch)
treecddd9991fc9d4b10a6996ebf4fafeeaf1d756cbe /textproc/saxon
parentf83af9fadf126ce99ee41552d898bc5eb04fd222 (diff)
downloadports-5fad809a5036ede0aa1484f20794ae259980b7fa.tar.gz
ports-5fad809a5036ede0aa1484f20794ae259980b7fa.zip
Notes
Diffstat (limited to 'textproc/saxon')
-rw-r--r--textproc/saxon/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/textproc/saxon/Makefile b/textproc/saxon/Makefile
index cf7f9cfaabdb..b80fde1503c0 100644
--- a/textproc/saxon/Makefile
+++ b/textproc/saxon/Makefile
@@ -22,15 +22,15 @@ NO_BUILD= yes
CONFLICTS= saxon-devel-8.*
+OPTIONS_DEFINE= DOCS
+
JARFILES= saxon-jdom.jar saxon.jar
PLIST_FILES+= ${JARFILES:S,^,%%JAVAJARDIR%%/,} bin/saxon
-.if !defined(NOPORTDOCS)
PORTDOCS= api api-guide.html changes.html conditions.html \
conformance.html dtdgen.html expressions.html \
extensibility.html extensions.html index.html \
instant.html limitations.html patterns.html samples.html \
saxon-style.css using-xsl.html xsl-elements.html
-.endif
SUB_LIST= SAXON_JARS="${JARFILES:S,^,${JAVAJARDIR}/,}"
SUB_FILES= saxon.sh
@@ -39,23 +39,21 @@ do-install:
@${ECHO_MSG} -n ">> Installing JARs in ${JAVAJARDIR}..."
.for JARFILE in ${JARFILES}
@${ECHO_MSG} -n " ${JARFILE}"
- @${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${STAGEDIR}${JAVAJARDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${STAGEDIR}${JAVAJARDIR}/
.endfor
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}..."
- @cd ${WRKSRC}/samples/ && \
+ cd ${WRKSRC}/samples/ && \
${FIND} . -type d -exec ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/{} \; && \
${FIND} . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/{} \;
@${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @cd ${WRKSRC}/doc/ && \
+ cd ${WRKSRC}/doc/ && \
${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \; && \
${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
@${ECHO_MSG} " [ DONE ]"
-.endif
@${ECHO_MSG} -n ">> Installing script in ${PREFIX}/bin..."
- @${INSTALL_SCRIPT} ${WRKDIR}/saxon.sh ${STAGEDIR}${PREFIX}/bin/saxon
+ ${INSTALL_SCRIPT} ${WRKDIR}/saxon.sh ${STAGEDIR}${PREFIX}/bin/saxon
@${ECHO_MSG} " [ DONE ]"
.include <bsd.port.mk>