aboutsummaryrefslogtreecommitdiff
path: root/textproc/scim-bridge
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2008-09-23 15:16:58 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2008-09-23 15:16:58 +0000
commit9445c3e0fc3aed1e64c6dd0539fabc50b43925f8 (patch)
treeb94cb71ca39616e44c59f232a841ef0f8021ef5d /textproc/scim-bridge
parent06f1fe1146c702dce9203ddef9fdd305ef59a775 (diff)
downloadports-9445c3e0fc3aed1e64c6dd0539fabc50b43925f8.tar.gz
ports-9445c3e0fc3aed1e64c6dd0539fabc50b43925f8.zip
Notes
Diffstat (limited to 'textproc/scim-bridge')
-rw-r--r--textproc/scim-bridge/Makefile39
-rw-r--r--textproc/scim-bridge/distinfo3
-rw-r--r--textproc/scim-bridge/pkg-descr7
3 files changed, 49 insertions, 0 deletions
diff --git a/textproc/scim-bridge/Makefile b/textproc/scim-bridge/Makefile
new file mode 100644
index 000000000000..797cb2929272
--- /dev/null
+++ b/textproc/scim-bridge/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: scim-bridge
+# Date created: 2008-09-10
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-bridge
+PORTVERSION= 0.4.15
+CATEGORIES= textproc
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= scim
+
+MAINTAINER= henry.hu.sh@gmail.com
+COMMENT= Scim-bridge agent (server)
+
+LIB_DEPENDS= scim-1.0.10:${PORTSDIR}/textproc/scim
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ENV= CPPFLAGS="-D__STDC_ISO_10646__"
+
+CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE} \
+ --enable-agent \
+ --disable-gtk2-immodule \
+ --disable-qt3-immodule \
+ --disable-qt4-immodule
+
+PLIST_FILES= bin/scim-bridge
+
+post-patch:
+ @${GREP} -lR "<malloc\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<malloc\.h>|<stdlib.h>|g'
+ @${GREP} -lR "<alloca\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<alloca\.h>|<stdlib.h>|g'
+
+.include <bsd.port.mk>
diff --git a/textproc/scim-bridge/distinfo b/textproc/scim-bridge/distinfo
new file mode 100644
index 000000000000..c347c6a9013b
--- /dev/null
+++ b/textproc/scim-bridge/distinfo
@@ -0,0 +1,3 @@
+MD5 (scim-bridge-0.4.15.tar.gz) = 03015dfdc01f8aa6ad933c695f47077b
+SHA256 (scim-bridge-0.4.15.tar.gz) = 802a65c412c44d7598397d2926ec6fe478fe6cc3c645047632a97ec54b2d8bcf
+SIZE (scim-bridge-0.4.15.tar.gz) = 753583
diff --git a/textproc/scim-bridge/pkg-descr b/textproc/scim-bridge/pkg-descr
new file mode 100644
index 000000000000..6df53122d040
--- /dev/null
+++ b/textproc/scim-bridge/pkg-descr
@@ -0,0 +1,7 @@
+Scim-bridge is wrapper library for SCIM, written in C. Scim-bridge
+is seperated in two parts, the agent and the clients. The agent is
+the IME server which communicates with SCIM. The clients are IMModules
+which communicate only with the agent so that there is no binary
+dependency between the clients and SCIM.
+
+WWW: http://www.scim-im.org/projects/scim_bridge/