aboutsummaryrefslogtreecommitdiff
path: root/textproc/scim-bridge
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2010-07-15 14:20:29 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2010-07-15 14:20:29 +0000
commit4b44e00a1d7bdb1f9184b5aed99a69847a5004c6 (patch)
tree24b178406371b0cc8f86f941bf59ddeee1ab4bbb /textproc/scim-bridge
parentc81ffae271967b641c440f6737ccae441435b3ce (diff)
downloadports-4b44e00a1d7bdb1f9184b5aed99a69847a5004c6.tar.gz
ports-4b44e00a1d7bdb1f9184b5aed99a69847a5004c6.zip
Notes
Diffstat (limited to 'textproc/scim-bridge')
-rw-r--r--textproc/scim-bridge/Makefile10
-rw-r--r--textproc/scim-bridge/distinfo6
-rw-r--r--textproc/scim-bridge/files/patch-configure29
3 files changed, 39 insertions, 6 deletions
diff --git a/textproc/scim-bridge/Makefile b/textproc/scim-bridge/Makefile
index 06168cea8113..e8ea9515a4fb 100644
--- a/textproc/scim-bridge/Makefile
+++ b/textproc/scim-bridge/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scim-bridge
-PORTVERSION= 0.4.15
-PORTREVISION= 4
+PORTVERSION= 0.4.16
CATEGORIES= textproc
MASTER_SITES= SF/scim/${PORTNAME}/${PORTVERSION}
@@ -20,7 +19,12 @@ USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-D__STDC_ISO_10646__"
+LICENSE= GPLv2 LGPL21
+LICENSE_FILES= ${WRKSRC}/doc/LICENSE.GPL ${WRKSRC}/doc/LICENSE.LGPL
+LICENSE_COMB= dual
+
+CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
+CXXFLAGS+= ${CPPFLAGS}
CONFIGURE_ARGS+=--with-libintl-prefix=${LOCALBASE} \
--enable-agent \
diff --git a/textproc/scim-bridge/distinfo b/textproc/scim-bridge/distinfo
index c347c6a9013b..2e1cabe4af78 100644
--- a/textproc/scim-bridge/distinfo
+++ b/textproc/scim-bridge/distinfo
@@ -1,3 +1,3 @@
-MD5 (scim-bridge-0.4.15.tar.gz) = 03015dfdc01f8aa6ad933c695f47077b
-SHA256 (scim-bridge-0.4.15.tar.gz) = 802a65c412c44d7598397d2926ec6fe478fe6cc3c645047632a97ec54b2d8bcf
-SIZE (scim-bridge-0.4.15.tar.gz) = 753583
+MD5 (scim-bridge-0.4.16.tar.gz) = 0011b178c4a0d2b0de26e7a14545323c
+SHA256 (scim-bridge-0.4.16.tar.gz) = 50d9da4a2842ab31cd3b27b1baacb14c458614bdb35855c6ecd09ab855ac702c
+SIZE (scim-bridge-0.4.16.tar.gz) = 508870
diff --git a/textproc/scim-bridge/files/patch-configure b/textproc/scim-bridge/files/patch-configure
new file mode 100644
index 000000000000..160af1af87e2
--- /dev/null
+++ b/textproc/scim-bridge/files/patch-configure
@@ -0,0 +1,29 @@
+
+$FreeBSD$
+
+--- configure.orig
++++ configure
+@@ -24583,6 +24583,7 @@
+
+ enable_gtk2_immodule="yes";
+ fi
++enable_gtk2_immodule="no";
+
+ # Check if we should build scim-bridge-qt-immodule
+
+@@ -24660,6 +24661,7 @@
+
+ enable_qt3_immodule="yes";
+ fi
++enable_qt3_immodule="no";
+
+
+ pkg_failed=no
+@@ -24736,6 +24738,7 @@
+
+ enable_qt4_immodule="yes";
+ fi
++enable_qt4_immodule="no";
+
+ ###########################################################
+ ## Definiation of compile args. ##