aboutsummaryrefslogtreecommitdiff
path: root/textproc/scim-input-pad/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-05-08 22:59:07 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-05-08 22:59:07 +0000
commit6cfbbfa38055bfde2022af088a293424daebff17 (patch)
tree51da8440b93c5c9b93246f61183541c60e0a58be /textproc/scim-input-pad/Makefile
parenta7ecba81994923221344ea9cc95955f4785b10d8 (diff)
downloadports-6cfbbfa38055bfde2022af088a293424daebff17.tar.gz
ports-6cfbbfa38055bfde2022af088a293424daebff17.zip
Notes
Diffstat (limited to 'textproc/scim-input-pad/Makefile')
-rw-r--r--textproc/scim-input-pad/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/scim-input-pad/Makefile b/textproc/scim-input-pad/Makefile
new file mode 100644
index 000000000000..9eef22d1b400
--- /dev/null
+++ b/textproc/scim-input-pad/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: scim-input-pad
+# Date created: 2005/05/06
+# Whom: chinsan <chinsan@mail2000.com.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-input-pad
+PORTVERSION= 0.1.0
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=scim
+
+MAINTAINER= chinsan@mail2000.com.tw
+COMMENT= SCIM add-on to input various symbols with on-screen pad
+
+BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+USE_GMAKE= yes
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
+
+.include <bsd.port.post.mk>